Wrong icon in dock for pantheon-terminal opened with Ctrl+Alt+T

Bug #1017171 reported by Arthur Tucker
106
This bug affects 19 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Plank
Undecided
Unassigned
elementary OS
Fix Released
Low
Sergey "Shnatsel" Davidoff
bamf (Ubuntu)
Undecided
Unassigned

Bug Description

When Pantheon Terminal is opened with Ctrl+Alt+T, Plank shows root terminal icon from some fallback theme.

ProblemType: Bug
DistroRelease: elementary 0.2
Package: elementary-desktop 1.271-0~341~precise1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
ApportVersion: 2.0.1-0ubuntu8+elementary3~precise1
Architecture: amd64
CrashDB: elementary_meta
Date: Sun Jun 24 08:58:38 2012
InstallationMedia: elementary OS 0.2 "Luna" - Build amd64 LIVE Binary 20120622-18:41
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Arthur Tucker (mars11) wrote :
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Thanks for your report! Could you please run "update-alternatives --query x-terminal-emulator" and post output?

Revision history for this message
Arthur Tucker (mars11) wrote :

Yeah, sure here's the output:
test@test-VirtualBox:~$ update-alternatives --query x-terminal-emulator
Link: x-terminal-emulator
Status: auto
Best: /usr/bin/pantheon-terminal
Value: /usr/bin/pantheon-terminal

Alternative: /usr/bin/pantheon-terminal
Priority: 35
test@test-VirtualBox:~$

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Well, this output indicates that running "x-terminal-emulator" should launch pantheon-terminal. Could you post a screenshot of the terminal that's started so we can understand the problem better?

Revision history for this message
Arthur Tucker (mars11) wrote :

Everything looks like the pantheon-terminal except for the icon on Plank.

summary: - Wrong Terminal when pressing Ctrl + Alt + T
+ Wrong icon in dock for pantheon-terminal opened with Ctrl+Alt+T
description: updated
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

I can confirm it. Must be a bug in either Plank or BAMF.

affects: elementaryos → plank
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Only starts happening after I kill Plank (and Cerbere respawns it).

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Okay, it does not start only after killing Plank.

I've tracked down one difference in Ctrl+Alt+T spawning, as opposed to normal launch: the terminal has "x-terminal-emulator" process name.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed
Robert Dyer (psybers)
Changed in plank:
status: New → Invalid
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Marking elementaryos affected because we'll have to do something in it to fix the bug (cherrypick a patch or something).

Changed in elementaryos:
status: New → Triaged
Revision history for this message
Dani Pratomo (daneepee) wrote :

I just change keyboard shortcut Ctrl+Alt+T from "x-terminal-emulator" to "pantheon-terminal" through System Settings

Changed in elementaryos:
importance: Undecided → Low
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

I wrote a wrapper to update-alternatives that happens to work around this bug. I'm working on integrating it in the OS.

Changed in elementaryos:
status: Triaged → In Progress
assignee: nobody → Sergey "Shnatsel" Davidoff (shnatsel)
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

The workaround should land with the next metapackage update.

You can obtain it manually with "sudo apt-get install user-specific-alternatives"

Changed in elementaryos:
status: In Progress → Fix Committed
Cody Garver (codygarver)
Changed in elementaryos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers