Ekiga Voice Over IP Suite

feature regression: ffmpeg lacks some video encoders (like h263+, MPEG4, maybe more...)

Reported by Yannick Defais on 2008-08-02
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ekiga
New
Undecided
Unassigned
Empathy
New
Undecided
Unassigned
GStreamer
New
Undecided
Unassigned
ffmpeg-debian (Debian)
Fix Released
Unknown
ffmpeg-debian (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

The current intrepid version of ffmpeg ( 3:0.svn20080206-11ubuntu1 ) lacks video encoders which were present in Hardy. I found h263+ and MPEG4, maybe more.

See the buildlog (configure part) for this version:
Enabled decoders:
aasc ac3 adpcm_4xm adpcm_adx adpcm_ct adpcm_ea adpcm_ea_r1 adpcm_ea_r2 adpcm_ea_r3 adpcm_ea_xas adpcm_g726 adpcm_ima_amv adpcm_ima_dk3 adpcm_ima_dk4 adpcm_ima_ea_eacs adpcm_ima_ea_sead adpcm_ima_qt adpcm_ima_smjpeg adpcm_ima_wav adpcm_ima_ws adpcm_ms adpcm_sbpro_2 adpcm_sbpro_3 adpcm_sbpro_4 adpcm_swf adpcm_thp adpcm_xa adpcm_yamaha alac amv ape asv1 asv2 atrac3 avs bethsoftvid bmp c93 cavs cinepak cljr cook cscd cyuv dca dnxhd dsicinaudio dsicinvideo dvbsub dvdsub dvvideo dxa eightbps ffv1 ffvhuff flac flashsv flic flv fourxm fraps gif h261 h263 h263i h264 huffyuv idcin imc indeo2 indeo3 interplay_dpcm interplay_video jpegls kmvc libgsm libgsm_ms loco mace3 mace6 mdec mjpeg mjpegb mmvideo mp2 mp3 mp3adu mp3on4 mpc7 mpc8 mpeg1video mpeg2video mpeg4 mpegvideo msmpeg4v1 msmpeg4v2 msmpeg4v3 msrle msvideo1 mszh nellymoser nuv pcm_alaw pcm_mulaw pcm_s16be pcm_s16le pcm_s16le_planar pcm_s24be pcm_s24daud pcm_s24le pcm_s32be pcm_s32le pcm_s8 pcm_u16be pcm_u16le pcm_u24be pcm_u24le pcm_u32be pcm_u32le pcm_u8 pcm_zork pcx png ptx qdm2 qdraw qpeg qtrle ra_144 ra_288 rawvideo roq roq_dpcm rpza rv10 rv20 sgi shorten smackaud smacker smc snow sol_dpcm sonic sp5x sunrast svq1 svq3 targa theora thp tiertexseqvideo tiff truemotion1 truemotion2 truespeech tscc tta txd ulti vb vc1 vcr1 vmdaudio vmdvideo vmnc vorbis vp3 vp5 vp6 vp6a vp6f vqa wavpack wmav1 wmav2 wmv1 wmv2 wmv3 wnv1 ws_snd1 xan_dpcm xan_wc3 xl xsub zlib zmbv
Enabled encoders:
ac3 adpcm_adx adpcm_g726 adpcm_ima_wav adpcm_ms adpcm_swf adpcm_yamaha asv1 asv2 bmp dnxhd dvbsub dvdsub dvvideo ffv1 ffvhuff flac flashsv flv gif huffyuv jpegls libgsm libgsm_ms libtheora libvorbis ljpeg mjpeg mp2 mpeg1video pam pbm pcm_alaw pcm_mulaw pcm_s16be pcm_s16le pcm_s24be pcm_s24daud pcm_s24le pcm_s32be pcm_s32le pcm_s8 pcm_u16be pcm_u16le pcm_u24be pcm_u24le pcm_u32be pcm_u32le pcm_u8 pcm_zork pgm pgmyuv png ppm qtrle rawvideo roq roq_dpcm rv10 rv20 sgi snow sonic sonic_ls svq1 targa tiff vorbis wmav1 wmav2 wmv1 wmv2 zlib zmbv
Enabled parsers:
aac ac3 cavsvideo dca dvbsub dvdsub h261 h263 h264 mjpeg mlp mpeg4video mpegaudio mpegvideo pnm vc1
Enabled demuxers:
aac ac3 aiff amr apc ape asf au avi avs bethsoftvid c93 daud dsicin dts dv dxa ea ea_cdata ffm flac flic flv fourxm gif gxf h261 h263 h264 idcin image2 image2pipe ingenient ipmovie lmlm4 m4v matroska mjpeg mm mmf mov mp3 mpc mpc8 mpegps mpegts mpegtsraw mpegvideo mtv mxf nsv nut nuv ogg pcm_alaw pcm_mulaw pcm_s16be pcm_s16le pcm_s8 pcm_u16be pcm_u16le pcm_u8 pva rawvideo redir rm roq rtsp sdp segafilm shorten siff smacker sol str swf thp tiertexseq tta txd vc1 vc1t vmd voc wav wc3 wsaud wsvqa wv yuv4mpegpipe
Enabled muxers:
ac3 adts aiff amr asf asf_stream au avi avm2 crc dv ffm flac flv framecrc gif gxf h261 h263 h264 image2 image2pipe m4v matroska matroska_audio mjpeg mmf mov mp2 mp3 mp4 mpeg1system mpeg1vcd mpeg1video mpeg2dvd mpeg2svcd mpeg2video mpeg2vob mpegts mpjpeg null nut ogg pcm_alaw pcm_mulaw pcm_s16be pcm_s16le pcm_s8 pcm_u16be pcm_u16le pcm_u8 psp rawvideo rm roq rtp swf tg2 tgp voc wav yuv4mpegpipe
Enabled protocols:
file http pipe rtp tcp udp
Enabled bsfs:
dump_extradata h264_mp4toannexb imx_dump_header mjpega_dump_header mov2textsub mp3_header_compress mp3_header_decompress noise remove_extradata text2movsub
Enabled indevs:
dv1394_demuxer libdc1394_demuxer oss_demuxer v4l2_demuxer v4l_demuxer x11_grab_device_demuxer
Enabled outdevs:
oss_muxer
License: GPL

Ref: http://launchpadlibrarian.net/16035009/buildlog_ubuntu-intrepid-i386.ffmpeg-debian_3%3A0.svn20080206-10ubuntu1_FULLYBUILT.txt.gz

Related branches

Yannick Defais (sevmek) wrote :

Hello,

This lack of some encoders affect the incoming Ekiga 3.0. (which will be in Intrepid)

Ekiga is able to use H263-98 and MPEG4.

You can test this using my PPA:
https://launchpad.net/~sevmek/+archive

Run ekiga in debug mode:
"ekiga -d 4"
In the beginning of the log you should see the problem (if ffmpeg in installed).

Best regards,
Yannick

Guillaume Desmottes (cassidy) wrote :

This will also probably affect Empathy which uses ffenc_h263 for video encoding.

Kota (kotayamaguchi1984) wrote :

gstreamer-ffmpeg package lacks several encoders because of this, though decoders are available.

Reinhard Tartler (siretart) wrote :

that totally correct and done deliberatly to comply to the requirements of our archive-admins.

You might want to raise a discussion on the ubuntu-devel mailing list about this, or escalate this to the technical board. There is little I can do as maintainer of the package about this.

Changed in ffmpeg-debian:
status: New → Triaged
Changed in ffmpeg-debian:
status: Unknown → New

Just a note here so Google can find it: This bug also affects any packages or scripts that rely on the mpeg2video encoder (such as m2tstoavi, etc.).

As a workaround, you can add the following lines to /etc/apt/preferences

Package: ffmpeg
Pin: release a=hardy-updates
Pin-Priority: 1001

And make sure you have an appropriate hardy-updates line in your /etc/apt/sources.list file.

Can we expect that by the time of Intrepid release that there will be an ffmpeg-free in main and an ffmpeg-nonfree, containing the missing codecs, in multiverse?

Because otherwise this is going to make a lot of people unhappy with Ubuntu, for no good reason.

Michael Robinson <email address hidden> writes:

> Can we expect that by the time of Intrepid release that there will be an
> ffmpeg-free in main and an ffmpeg-nonfree, containing the missing
> codecs, in multiverse?

I have preparations that creating such a package is made rather easy,
however I'm not sure that I'll manage to put a package for this in place
in time.

I did hope that some folks from plf or medibuntu would contact me about
that, but that didn't happen :-(

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Reinhard Tartler (siretart) wrote :

okay, for intrepid I have replacement package that enable h263, mpeg2video, etc.
please see https://launchpad.net/~motumedia/+archive, add that ppa and install:

apt-get install libavcodec-unstripped-51

that should bring back the missing encoders.

feedback on them is VERY appreciated if we want to have this package in intrepid/multiverse.

Ian Barton (ian-manor-farm) wrote :

Reinhard,

Thanks very much for making your package available. However, you don't seem to have enabled aac support:

FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu3, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libfaad --enable-libfaadbin --enable-liba52 --enable-liba52bin --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-altivec --disable-vis --enable-shared --disable-static
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.7.0
  libavdevice version: 52.0.0
  built on Oct 3 2008 22:40:31, gcc: 4.3.2
Input #0, mpeg, from '/media/disk/Videos/encode/Great_British_Journeys_-_2008-10-03,_4-59_PM_-_William_Cobbett's_Rural_Rides.mpg':
  Duration: 00:45:50.8, start: 0.242767, bitrate: 2762 kb/s
    Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x576 [PAR 64:45 DAR 16:9], 3748 kb/s, 25.00 tb(r)
    Stream #0.1[0x1c0]: Audio: mp2, 48000 Hz, stereo, 192 kb/s
Unknown encoder 'aac'

I have all the Intrepid faac libs installed, so I think the error is probably due to ffmpeg.

Ian.

Reinhard Tartler (siretart) wrote :

package now available as libavcodec-unstripped-51 in intrepid/multiverse

Changed in ffmpeg-debian:
status: Triaged → Fix Released
Guillaume Desmottes (cassidy) wrote :

Note that the H264 encoder is still missing. See https://bugs.launchpad.net/ubuntu/+source/ffmpeg/+bug/303537

Changed in ffmpeg-debian (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.