create armadaxp netboot directory and move files into it

Bug #1010708 reported by mahmoh on 2012-06-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Eilt project
Low
Adam Conrad
debian-installer (Ubuntu)
Undecided
Adam Conrad
Precise
Undecided
Adam Conrad

Bug Description

Build Version/Date: http://ports.ubuntu.com/ubuntu-ports/dists/quantal/main/installer-armhf/20101020ubuntu147/

Environment used for testing: armadaxp1

Summary: create armadaxp netboot directory and move files into it

Steps to Reproduce: download the .../armadaxp/netboot/u* files for install

Expected result: files are preset

Actual result: files are misplaced one level up and the netboot directory is missing

Note:

http://ports.ubuntu.com/ubuntu-ports/dists/quantal/main/installer-armhf/current/images/armadaxp/uImage

should be:

http://ports.ubuntu.com/ubuntu-ports/dists/quantal/main/installer-armhf/current/images/armadaxp/netboot/uImage

Same goes for the uInitrd.

mahmoh (mahmoh) on 2012-06-08
visibility: private → public
Changed in debian-installer (Ubuntu):
status: New → Confirmed
Changed in eilt:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Adam Conrad (adconrad)
Adam Conrad (adconrad) on 2012-06-08
Changed in debian-installer (Ubuntu):
milestone: none → precise-updates
milestone: precise-updates → none
Adam Conrad (adconrad) on 2012-06-08
Changed in debian-installer (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu148

---------------
debian-installer (20101020ubuntu148) quantal; urgency=low

  * Fix armadaxp netboot uImage/uInitrd install paths (LP: #1010708)
  * Bring armadaxp and highbank netboot.cfg in line with other arches
 -- Adam Conrad <email address hidden> Fri, 08 Jun 2012 16:41:44 -0600

Changed in debian-installer (Ubuntu):
status: Confirmed → Fix Released
Adam Conrad (adconrad) on 2012-06-11
Changed in debian-installer (Ubuntu Precise):
assignee: nobody → Adam Conrad (adconrad)

Hello MMorana, or anyone else affected,

Accepted debian-installer into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/debian-installer/20101020ubuntu136.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in debian-installer (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Verified that the armadaxp/netboot bits now live where they should in precise-proposed.

tags: added: verification-done
removed: verification-needed
Adam Conrad (adconrad) wrote :

FWIW, I've also taken the decision to fix precise/main/installer-armhf/current/ to match the layout we've pushed to precise-proposed, so that people don't get terribly confused swapping back and forth between the two.

Robie Basak (racb) wrote :

This just caused a regression from my perspective, because we had tools that were working against Precise and just broke because the armadaxp netboot images just vanished (from the perspective of the script).

I notice that the server install instructions have already been updated to link to the new location, so perhaps this is not so bad on this occasion. The amount of tooling around armadaxp is currently fairly limited, so it is probably better overall to have Precise's netboot location consistent since it won't be too hard to update things.

But in future, other automated tools (eg. MAAS) will expect to find the netboot images at the same location that they were at release time. Please consider these (and tools used by users that we can't necessarily update) before moving netinst image URLs after release in future.

Adam Conrad (adconrad) wrote :

Moving things post-release is certainly an unprecedented sort of deal, and not something I'd normally do, but in this case, the only "customers" are people who the change was communicated with, and not random third parties with retail hardware. Fixing this now, instead of having two sets of installation instructions for the next five years, seemed the saner route.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package debian-installer - 20101020ubuntu136.1

---------------
debian-installer (20101020ubuntu136.1) precise-proposed; urgency=low

  [ Colin Watson ]
  * Use udebs from precise-security, precise-proposed, and precise-updates.
  * Move to 3.2.0-26 kernels.
  * Move armel/omap4 and armhf/omap4 to 3.2.0-1415 kernels.
  * Move armhf/armadaxp to 3.2.0-1604 kernels.

  [ Adam Conrad ]
  * Fix armadaxp netboot uImage/uInitrd install paths (LP: #1010708)
 -- Colin Watson <email address hidden> Wed, 04 Jul 2012 10:53:44 +0100

Changed in debian-installer (Ubuntu Precise):
status: Fix Committed → Fix Released
Adam Conrad (adconrad) on 2012-12-01
Changed in eilt:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers