FTP VSFTPD Not login or Not change file

Bug #991871 reported by Andi Susilo
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Easy Hosting Control Panel for Ubuntu
Fix Released
High
Unassigned

Bug Description

I read the information here
http://ehcp.net/?q=node/1257
and I tried to fix it, it's not a problem on Ubuntu 12:04, but there is little problem with the vsftpd.conf configuration and permissions on the folder,,
way is:
first: open the file classapp.php and look at line 216 var $ ftpuser = "vsftpd"; change it to var $ ftpuser = "www-data";
like the picture below http://a7.sphotos.ak.fbcdn.net/hphotos-ak-snc7/575395_2798121807306_1686336794_1788103_2052652746_n.jpg

second: restart daemon ehcp, sudo service ehcp restart and test add new domain or Syncronize domains,, and see with ls-l it will be like this http://a8.sphotos.ak.fbcdn.net/hphotos-ak-ash3/529816_2798130807531_1686336794_1788107_1134708575_n.jpg

third: You cange file vsftpd.conf in folder /etc/ fox guest_username = www-data and nopriv_user = www-data, as shown below http://a6.sphotos.ak.fbcdn.net/hphotos-ak-ash3/s720x720/552890_2798124047362_1686336794_1788104_1206805316_n.jpg

to four: Restart service vsftpd, sudo service vsftpd restart, and now you can login and change files with FTP http://a4.sphotos.ak.fbcdn.net/hphotos-ak-ash2/156117_2798125007386_1686336794_1788105_1409979177_n.jpg look at status saved.

And your FTP server with VSFTPD resolve,,

Tags: vsftpd
Andi Susilo (andiunpam)
description: updated
Revision history for this message
Phillip Beckford (budgierless) wrote :

Confirmed, fix dose work, thanks

Revision history for this message
Phillip Beckford (budgierless) wrote :
Changed in ehcp:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Phillip Beckford (budgierless) wrote :

can you check for timeouts, this is important, just to be sure? this may also need to be adjusted for new config.

Revision history for this message
ehcpdeveloper (ehcpdeveloper) wrote :

will test and merge, thanks.

Revision history for this message
ehcpdeveloper (ehcpdeveloper) wrote :

would there be some other problem, by chaning username from vsftpd to www-data , for future ?

Revision history for this message
Phillip Beckford (budgierless) wrote :

vsftpd user is used for many other files also, so i would not remove it, because it may add other problems.

Revision history for this message
Phillip Beckford (budgierless) wrote :

Also it maybe needed future ubuntu vsftpd updates.

Revision history for this message
Phillip Beckford (budgierless) wrote :

I'm more worried about the timeouts, it seem too soon, is this a vsftpd or php.ini issue? if php.ini then its not an issue, but please someone check this.

Response: 421 Timeout.
Error: Connection closed by server

i get this when FTP is idle for small time.

Revision history for this message
Andi Susilo (andiunpam) wrote :

yes this is not permanent, if you click Fix Mail Configuration vsftpd.conf the configuration will return to normal, then you have to change it again or can be permanently changed, the configuration is in file install_lib.php on line 817

http://a6.sphotos.ak.fbcdn.net/hphotos-ak-ash4/s720x720/294998_2803334937631_1686336794_1791193_1016951009_n.jpg

Changed in ehcp:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions