Area selection square is opaque (at least in nautilus)

Bug #972156 reported by Alan Morgan
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
elementary Stylesheet
Fix Released
Undecided
Unassigned

Bug Description

When holding down the left mouse button and moving the cursor in nautilus, a square is drawn which selects the items which are within the square. A problem with the gtk3 version of this theme is that this square is an opaque white, meaning that it is harder to know what is being selected.

Revision history for this message
Alan Morgan (alanmorgan) wrote :
Revision history for this message
Timo Reimerdes (timorei) wrote :

/* Nautilus Mouse-Drag-Selection (transparent) */
.rubberband {
    background-color: alpha (@selected_bg_color, 0.35);
    border-color: @selected_bg_color;
    border-radius: 0px;
    border-style: solid;
    border-width: 1px;
}

Fixes this (it's working fine in marlin).

Revision history for this message
Artyom Zorin (azorin) wrote :

It works in Marlin but it doesn't in Nautiuls :(
The weird thing is that this exact code for the rubberband is used in other themes such as Radiance and it works there, but it doesn't work in the Elementary GTK+ theme.

Alan Morgan (alanmorgan)
Changed in egtk:
status: New → Confirmed
Revision history for this message
Artyom Zorin (azorin) wrote :

I found a fix to the problem.
In the gtk-widgets.css file change this:

.rubberband {
    background-color: alpha (@selected_bg_color, 0.35);
    border-color: @selected_bg_color;
    border-style: solid;
    border-width: 1px;
}

to this:

.view.rubberband,
.rubberband {
    background-color: alpha (@theme_selected_bg_color, 0.35);

    border-color: @theme_selected_bg_color;
    border-style: solid;
    border-width: 1px;
    border-radius: 2px;
}

Changed in egtk:
status: Confirmed → Fix Committed
Revision history for this message
Daniel Fore (danrabbit) wrote :

Hey AZorin, thanks for your fix. For future reference, please don't mark a bug as "fix committed" until the fix has actually landed in bzr. Marking it pre-maturely can mean that this bug ends up never getting actually fixed because the tracker says it's already fixed even thought it's not.

Daniel Fore (danrabbit)
Changed in egtk:
milestone: none → 3.2
Daniel Fore (danrabbit)
Changed in egtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers