Headerbar text looks off in the new dark theme [$15]

Bug #1345643 reported by Nathan Dyer on 2014-07-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
elementary Stylesheet
Fix Released
Medium
Unassigned

Bug Description

Text inside of headerbars looks off when using the dark theme. The white color sticks out quite badly. Making the labels insensitive seems to fix the problem temporarily, but introduces more issues on other systems/themes.

A screenshot of the problem is attached.

Nathan Dyer (nathandyer) wrote :

Confirmed in Noise using `GTK_THEME=elementary:dark noise`

Changed in egtk:
status: New → Confirmed
importance: Undecided → Medium
summary: - Headerbar text looks off in the new dark theme
+ Headerbar text looks off in the new dark theme [$15]
tags: added: bounty
Daniel Fore (danrabbit) on 2014-08-18
Changed in egtk:
milestone: none → freya-beta2
status: Confirmed → Fix Committed
Nathan Dyer (nathandyer) wrote :

I am still affected by the bug. Specifically with Vocal, I have a Gtk.Label inside of a Gtk.Box that I have set as the title widget in the headerbar. The workaround is currently active in the PPA builds, but as soon as you comment out the "label.sensitive = false" lines in the PlaybackBox.vala file the bug becomes apparent.

Daniel Fore (danrabbit) wrote :

Ah, I thought the bug was fixed because I wasn't experiencing it. This is the problem with workarounds :p I'll branch vocal and see if I can figure out the problem.

Daniel Fore (danrabbit) on 2015-02-09
Changed in egtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers