Should Have Equal Spacing Between On/Off switch

Bug #1013844 reported by NewfieBullet on 2012-06-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
elementary Stylesheet
Fix Released
Undecided
Unassigned

Bug Description

Not sure if this has to do with granite, the elementary theme, or just GTK3. So just mark it invalid if you feel the need to.

Like it says in the title, the on/off switch switch has unequal spacing between choosing on or off.

I have images below.

NewfieBullet (n-bullet) wrote :
description: updated
NewfieBullet (n-bullet) wrote :
no longer affects: granite
James Ye (lolz836) wrote :

This is caused by the design of the switch in eGTK. The slider in the switch is quite small, and for there to be equal spacing, either the whole switch has to be tiny, the slider longer (both not nice), or have a different design for switches with equal spacing.
But to work around this simply click on the slider. It's faster anyway.

Cody Garver (codygarver) wrote :

I'm unable to reproduce this, is it still happening?

Changed in egtk:
status: New → Incomplete

Still occurs

Changed in egtk:
status: Incomplete → New

Try dragging the silver circle the the opposite position. At 2/3 of the distance it gets stuck

Daniel Fore (danrabbit) on 2013-04-22
Changed in egtk:
status: New → In Progress
Daniel Fore (danrabbit) on 2013-04-23
Changed in egtk:
status: In Progress → Fix Committed
milestone: none → luna-beta2
status: Fix Committed → Triaged
milestone: luna-beta2 → 4.0
Daniel Fore (danrabbit) on 2013-09-08
Changed in egtk:
status: Triaged → Fix Committed
Daniel Fore (danrabbit) on 2014-05-25
Changed in egtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers