getaddrinfo() writes DNS queries to random file descriptors under high load

Bug #1421393 reported by Michael Hale on 2015-02-12
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
eglibc
Unknown
Unknown
eglibc (Ubuntu)
Undecided
Unassigned

Bug Description

I'm reporting this bug that was resolved upstream in the hopes that it might be backported to one of the versions of eglibc that is supported by ubuntu. This is fixed in 2.20 but the most recent version shipped by ubuntu in any flavor is 2.19.

The upstream report can be found here https://sourceware.org/bugzilla/show_bug.cgi?id=15946.

This is a big issue for anyone resolving DNS queries with some amount of concurrency. The go-lang project struggled with this and we have similar issues at heroku: https://github.com/golang/go/issues/6336#issuecomment-66085142.

If there is a more appropriate way to bring attention to this issue with the goal of getting a backport in the works for say trusty please let me know.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eglibc (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.