EeeBotu announces bugs multiple times

Bug #484337 reported by Philip Muškovac on 2009-11-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
EeeBotu
Undecided
Unassigned

Bug Description

here's an excerpt from #u-b-a on the 17th November 2009 Berlin local time:

[18:17:22] <EeeBotu> New bug #484318 in ubuntuone-client (main): "ubuntuone needs keyring unlock" [Undecided, New] https://bugs.launchpad.net/bugs/484318
[18:18:27] <EeeBotu> New bug #484309 in sound-juicer (universe): "Sound Juicer has a mind of its own...(grrrrr!)" [Undecided, New] https://bugs.launchpad.net/bugs/484309
[18:18:32] <EeeBotu> New bug #484310 in kvm (main): "XP guest bluescreens on startup" [Undecided, New] https://bugs.launchpad.net/bugs/484310
[18:20:46] <EeeBotu> New bug #484317 in gdm (main): "GDM allows root logins" [Undecided, New] https://bugs.launchpad.net/bugs/484317
[18:20:48] <EeeBotu> New bug #484318 in ubuntuone-client (main): "ubuntuone needs keyring unlock" [Undecided, New] https://bugs.launchpad.net/bugs/484318
[18:21:52] <EeeBotu> New bug #484309 in sound-juicer (universe): "Sound Juicer has a mind of its own...(grrrrr!)" [Undecided, New] https://bugs.launchpad.net/bugs/484309
[18:21:54] <EeeBotu> New bug #484310 in kvm (main): "XP guest bluescreens on startup" [Undecided, New] https://bugs.launchpad.net/bugs/484310
[18:23:00] <EeeBotu> New bug #484317 in gdm (main): "GDM allows root logins" [Undecided, New] https://bugs.launchpad.net/bugs/484317
[18:23:06] <EeeBotu> New bug #484318 in ubuntuone-client (main): "ubuntuone needs keyring unlock" [Undecided, New] https://bugs.launchpad.net/bugs/484318

notice bug #484318 being announced 3 times. This is very confusing especially for people new to the bug triaging process as they might think those are duplicate bug reports (like the reporter pressing the button multiple times) only to find out that they're one and the same. It makes the bug announcements hard to read too since you need to filter out what bugs weren't already announced.

Related branches

Philip Muškovac (yofel) on 2009-11-17
description: updated
C de-Avillez (hggdh2) wrote :

Thank you for opening this bug and helping make triaging, er, Ubuntu, better. ;-)

I did a quick look at the eeeBotu logs, and indeed I see duplicate announcements. I am not sure to what attribute it right now, but I am tending to some sort of problem on the interface.

I will increase the eeeBotu log level, and will check on the interface also.

Changed in eeebotu:
assignee: nobody → C de-Avillez (hggdh2)
status: New → Confirmed

Sometimes also the RSS feed is not very reliable. I should make
EeeBotu keep a queue of the most recent 20 echoed bug numbers, and
check there before echoing to make sure it doesn't duplicate it.
Should be pretty easy.

Michael Rooney (mrooney) wrote :

I've pushed a potential fix to trunk, which handles keeping track of what it was already announced in a much more robust fashion; I can see where it could lose track before.

I gave it a basic smoke test and it appears well; hggdh, would you be able to update the checkout/branch on the server and restart it?

Changed in eeebotu:
status: Confirmed → Triaged
C de-Avillez (hggdh2) wrote :

heh. Just found that I lost remote access to the machine -- seems to be a DNS issue. I will get it done this evening.

C de-Avillez (hggdh2) wrote :

Marking fix released. Thanks, Mike!

Changed in eeebotu:
assignee: C de-Avillez (hggdh2) → nobody
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers