ecryptfs fails sporadically

Bug #716332 reported by Sam Liddicott on 2011-02-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eCryptfs
High
Unassigned
ecryptfs-utils (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ecryptfs-utils

ecryptfs seems unreliable. In a recent case I performed a git fsck on a large samba4 repo, like this:

git fsck --full --verbose --strict

it failed with a corrupt dangling commit, and dmesg showed:

[961417.528106] ecryptfs_read_and_validate_header_region: Error reading header region; rc = [-4]
[961417.528150] Valid eCryptfs headers not found in file header region or xattr region
[961417.528156] Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO

I repeated the git fsck and it worked without problem, and dmesg showed nothing.

as git fsck does not repair, we can clude that different data was read the second time. The chance of a bad git appearing good by accident is very small. The fact that the dmesg error shows when git fsck fails suggests that the failure occured the first time and not the second time.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: libecryptfs0 83-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-23.41-generic-pae 2.6.35.7
Uname: Linux 2.6.35-23-generic-pae i686
NonfreeKernelModules: fglrx wl
Architecture: i386
Date: Thu Feb 10 09:13:38 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: ecryptfs-utils

Sam Liddicott (sam-liddicott) wrote :
Dustin Kirkland  (kirkland) wrote :

Hi Sam,

Thanks for the bug report, and reproduce instructions.

For what it's worth, I just cloned samba4, and did the fsck (which took ~7 minutes), but it completed without error, and without any dmesg noise. Was just one test, and I'll retest now, but I wanted to confirm that at least my first run completed without error.

This is:
Linux x201 2.6.38-2-generic #29-Ubuntu SMP Fri Feb 4 13:03:04 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
ecryptfs-utils 85-0ubuntu1

Changed in ecryptfs:
importance: Undecided → High
status: New → Incomplete
Changed in ecryptfs-utils (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Dustin Kirkland  (kirkland) wrote :

Hmm, I ran your git fsck 10 times in a row successfully on the above configuration. I guess I'm going to need a bit more to reproduce this...

Sam Liddicott (sam-liddicott) wrote :

Well... I can't reproduce it easily...

At the time I had a samba compile running in a bin-mounted unionfs chroot
as well as virtualbox running windows 2008 with the container file
both of which were based in my ecyrptfs mounted homedir

My machine is dual core and was running lowish on RAM, probably 120 MB free and 95MB buffers

(I've had a git corruption too which I was able to fix using low level git commands to extract a git object from a backup and re-insert it into the damaged repo).

I don't think this report can be much more than anecdotal evidence for the developers of problems which may exist under load.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers