ecrypts file corruption

Bug #655615 reported by Arne Caspari on 2010-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eCryptfs
High
Tyler Hicks
ecryptfs-utils (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ecryptfs-utils

I am trying to build an Angstrom/Openembedded image. The process involves a lot of CPU and disk activity. The build home is on my home partition which is using ecrypt fs.

During the build I get occasional messages in the kernel log like:
[440102.824861] Valid eCryptfs headers not found in file header region or xattr region
[440102.824867] Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO

Consequently the build stops with an IO error. Continuing the build usually fixes this issue ( ie. the files can be correctly read the second time ).

But unfortunately from time to time, the files get corrupted which means that they only contain binary data garbage!

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ecryptfs-utils 83-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-24-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Wed Oct 6 11:51:17 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.utf8
SourcePackage: ecryptfs-utils

Arne Caspari (arne-datafloater) wrote :
Arne Caspari (arne-datafloater) wrote :

I moved the build environment out of the encrypted home folder to an unencrypted part of the same harddisk and made a complete rebuild of the Angstrom image. This time the build went through without any issues. There were no IO errors and more importantly, there was no file corruption.

I think this pretty much confirms that ecryptfs is the cause for the file corruption

Dustin Kirkland  (kirkland) wrote :

I suspect that this might be a duplicate of Bug #509180.

Subscribing upstream.

Tyler, can you take a look at this and see if you think this is a dupe of our other corruption issue?

Thanks!

Changed in ecryptfs-utils (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Changed in ecryptfs:
status: New → Incomplete
importance: Undecided → High
assignee: nobody → Tyler Hicks (tyhicks)
Tyler Hicks (tyhicks) wrote :

I'm fairly certain that this is a dupe of Bug #509180, which has a fix released.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers