Drive ran out of storage, now has space missing

Bug #626088 reported by Nick Semenkovich on 2010-08-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eCryptfs
Undecided
Unassigned

Bug Description

A few days ago, a batch process I was running accidentally exhausted 100% of my partition's storage. One directory on this partition is encrypted with eCryptfs

After killing the process, I tried to free up some space by deleting files from the encrypted directory. Strangely, after RM-ing ~4 GB of files, I noticed that "df -h" showed that there wasn't any additional free space.

df's "Used" column value was decreasing, but the "Avail" column wasn't increasing.

When I RM-ed files outside of the encrypted directory (but on the same partition), "df -h" behaved normally (with "Used" decreasing as "Avail" increased).

dmesg had many messages of the type:
[ 140.267890] ecryptfs_encrypt_page: Error attempting to write lower page; rc = [-28]
[ 140.267894] ecryptfs_write_end: Error encrypting page (upper index [0x0000000000000000])

Those messages stopped appearing (after space was freed and I rebooted), but now there are intermittent messages of the type:
[18819.518304] Valid eCryptfs headers not found in file header region or xattr region
[18819.518311] Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO

As of now, eCryptfs seems to be working fine, and all the encrypted files (that i know of) are completely accessible.

However, the dmesg warning still appears intermittently (is there any way to identify what file access is causing it?).

** More importantly, the ~4 GB of files (that I deleted during the out-of-storage event), seems to have vanished from accessible storage:

$ df -h
...
/var/encrypted/.Private
                      74G 40G 30G 58% /var/encrypted
...

Any advice?

Nick Semenkovich (semenko) wrote :

[I guess the other dmesg warning was probably bug #372014 -- removing 0 sized files fixed it. ]

For completeness:
$ uname -a
Linux maverick-dev 2.6.35-19-generic #26-Ubuntu SMP Thu Aug 26 19:13:04 UTC 2010 x86_64 GNU/Linux

Filesystem:
/dev/md0 on / type ext4 (rw,noatime,errors=remount-ro,commit=0)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers