Comment 2 for bug 359997

Maybe I did choose to encrypt the fs. But my concern, and the reason for this bug, is that the pop-up confused me. It was not clear what the purpose was. Is this asking for my user password? Or is it asking for a master key that I can use to decrypt my directory in the event of OS failure? If so, it would be good to confirm the password twice rather than once.

======================
$ mount | grep ecryptfs
/home/[username]/.Private on /home/[username] type ecryptfs (ecryptfs_sig=cc21271a0.......,ecryptfs_fnek_sig=c72a126b8.......,ecryptfs_cipher=aes,ecryptfs_key_bytes=16)

$ ls -aFl | grep ecryptfs
lrwxrwxrwx 1 [username] [username] 104 2009-02-08 10:10 .ecryptfs -> /var/lib/ecryptfs/[username]/
======================

So I attempted to run the command by hand, and it appears to be failing. I tried my user login password, and also tried the passphrase that I had used in the initial pop-up box above:

$ ecryptfs-unwrap-passphrase .ecryptfs
Passphrase: [password]
Warning: Using default salt value (undefined in ~/.ecryptfsrc)
Error: Unwrapping passphrase failed [-5]
Info: Check the system log for more information from libecryptfs

/var/log/syslog:
Apr 14 06:48:13 [hostname] ecryptfs-unwrap-passphrase: Error attempting to read encrypted passphrase from file [.ecryptfs]; size = [4294967295]