Regression in mount helper filename encryption support

Bug #331948 reported by Tyler Hicks on 2009-02-20
6
Affects Status Importance Assigned to Milestone
eCryptfs
High
Michal Hlavinka
ecryptfs-utils (Ubuntu)
High
Dustin Kirkland 

Bug Description

Release -70 or -71 caused a regression in filename encryption support in the mount helper.

To reproduce:
---
#> mount -t ecryptfs /mnt/.ecryptfs-ext3/ /mnt/ecryptfs-ext3/
Select key type to use for newly created files:
 1) openssl
 2) passphrase
Selection: 2
Passphrase:
Select cipher:
 1) aes: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 2) blowfish: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 3) des3_ede: blocksize = 8; min keysize = 24; max keysize = 24 (not loaded)
 4) twofish: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 5) cast6: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 6) cast5: blocksize = 8; min keysize = 5; max keysize = 16 (not loaded)
Selection [aes]:
Select key bytes:
 1) 16
 2) 32
 3) 24
Selection [16]:
Enable plaintext passthrough (y/n) [n]:
Enable filename encryption (y/n) [n]: y
Error attempting to evaluate mount options: [-16] Device or resource busy
Check your system logs for details on why this happened.
Try updating your ecryptfs-utils package, and/or
submit a bug report on https://launchpad.net/ecryptfs
---

Normally, it would ask for the fnek sig, but now it errors out with -16. I'm not seeing anything related in the logs.

Tyler Hicks (tyhicks) on 2009-02-20
Changed in ecryptfs:
importance: Undecided → High
status: New → Confirmed
Tyler Hicks (tyhicks) on 2009-02-21
Changed in ecryptfs:
assignee: nobody → mhlavink
Changed in ecryptfs-utils:
assignee: nobody → kirkland
status: New → Confirmed
Changed in ecryptfs:
status: Confirmed → Triaged
Changed in ecryptfs-utils (Ubuntu):
importance: Undecided → High
Changed in ecryptfs:
status: Triaged → Fix Committed
Changed in ecryptfs-utils (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ecryptfs-utils - 72-0ubuntu1

---------------
ecryptfs-utils (72-0ubuntu1) jaunty; urgency=low

  [ Dustin Kirkland ]
  * src/utils/ecryptfs-[u]mount-private: print message about cd $PWD,
    LP: #332331
  * doc/manpage/*: manpage updates
  * debian/ecryptfs-utils.prerm: prevent removal of ecryptfs-utils
    package, if in use, LP: #331085
  * src/utils/ecryptfs-setup-private:
    - allow for LDAP-based logins, LP: #317307
    - add --noautomount, --noautoumount options, LP: #301759

  [ Tyler Hicks ]
  * src/libecryptfs/cipher_list.c: ignore unknown ciphers, LP: #335632
  * doc/manpage/ecryptfs.7: add key sig mount options info, LP: #329491
  * src/utils/mount.ecryptfs.c: scrub unknown option

  [ James Dupin ]
  * doc/manpage/fr/*: initial cut at french manpages

  [ Michal Hlavinka ]
  * src/libecryptfs/module_mgr.c: fix mount parameter handling on
    interactive mounting, LP: #331948

 -- Dustin Kirkland <email address hidden> Wed, 18 Mar 2009 18:53:11 -0500

Changed in ecryptfs-utils:
status: Fix Committed → Fix Released
Changed in ecryptfs:
status: Fix Committed → Fix Released
bodhi.zazen (bodhi.zazen) wrote :

I am getting the same error message with ecryptfs-utils - 73-0ubuntu1 :(

Hmm, really? On Jaunty? I just tested, and it's working well for me...

:-Dustin

bodhi.zazen (bodhi.zazen) wrote :

yes, really, lol

I can post the output if you like. It is a fresh install of Alpha 6.

Version of ecryptfs-utils as above.

What output would you like to see ? It looks like the first post ;)

Dustin Kirkland  (kirkland) wrote :

Bodhi-

Please post:
 $ dpkg -l | grep ecryptfs

And the same sort of output that Tyler posted.

:-Dustin

bodhi.zazen (bodhi.zazen) wrote :

Dustin :

Thank you for your time, but ...

As this was broken, and the beta was released, I updated to the beta (apt-get dist-upgrade) and rebooted.

With the update the problem was resolved. w00t.

Dustin Kirkland  (kirkland) wrote :

Awesome, thanks. I hoped that would be the case ;-) Cheers!

:-Dustin

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers