mount -t ecryptfs doesn't work

Bug #329176 reported by Adam Sommer on 2009-02-13
2
Affects Status Importance Assigned to Milestone
eCryptfs
High
Dustin Kirkland 

Bug Description

Executing:

  sudo mount -t ecryptfs /srv /srv

On Jaunty kernel version linux-image-2.6.28-7-server-2.6.28-7.20 resulted in:

Feb 13 00:46:23 crypto mount.ecryptfs: Could not open library handle
Feb 13 00:46:23 crypto mount.ecryptfs: Could not open library handle
Feb 13 00:46:26 crypto mount.ecryptfs: Passphrase key already in keyring
Feb 13 00:46:26 crypto mount.ecryptfs: ecryptfs_add_passphrase_key_to_keyring: Error adding auth tok with sig [616b5c8a415a0000] to the keyring; rc = [1]

Also, using the ecryptfs-setup-private produced:

Feb 13 00:45:21 crypto sudo: Warning: Using default salt value (undefined in ~/.ecryptfsrc)
Feb 13 00:45:22 crypto sudo: Error attempting to open [/home/sommer/.ecryptfs/wrapped-passphrase] for reading
Feb 13 00:45:22 crypto sudo: Error attempting to unwrap passphrase from file [/home/sommer/.ecryptfs/wrapped-passphrase]; rc = [-5]
Feb 13 00:45:22 crypto sudo: Error adding passphrase key token to user session keyring; rc = [-5]
Feb 13 00:45:28 crypto ecryptfs-add-passphrase: Passphrase key already in keyring
Feb 13 00:45:28 crypto ecryptfs-add-passphrase: ecryptfs_add_passphrase_key_to_keyring: Error adding auth tok with sig [616b5c8a415a0000] to the keyring; rc = [1]

Please let me know if you need any more information.

Thanks

Dustin Kirkland  (kirkland) wrote :

Thanks for the report, Adam. I'm on it ;-)

:-Dustin

Changed in ecryptfs:
assignee: nobody → kirkland
importance: Undecided → High
status: New → In Progress
Dustin Kirkland  (kirkland) wrote :

Okay, this one is a doosey.

The root cause of this buried very, very, very deep in our kernel+glibc toolchain. The gory details are in Bug #329264.

I have committed a hackey workaround that will fix this for us for now. But we need to get the toolchain fixed too.

:-Dustin

Changed in ecryptfs:
status: In Progress → Fix Committed
Dustin Kirkland  (kirkland) wrote :

Fixed in ecryptfs-utils-70.

:-Dustin

Changed in ecryptfs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers