eCryptsfs drastically slows down Synthing (and ls -lR)

Bug #1737510 reported by Vaclav Cermak on 2017-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eCryptfs
Undecided
Unassigned

Bug Description

I've tried encryption on a new installation of 17.10. Then I realized, that eCryptfs causes drastic slowdown of Syncthing directory scan. I have two similar machines, both with the same data on 7200rpm hdd and this scan takes several minutes (3-4) on machine without encryption and about 45min on machine with encryption.

For confirmation i tried:

- stop Syncthing and start it again - scan is fast, files metadata are probably in cache

- stop Syncthing, empty fs caches, start again - scan is horribly slow (mentioned 45min)

- do simple ls -LR > file on machine with and without encryption. On encrypted one it is painfully slow, just like as Syncthing directory scan

Other synchronization systems are probably affected in a similar way.

Vaclav Cermak (disnel) wrote :

Is it probably related to this very old report:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/587408

Vaclav Cermak (disnel) wrote :

And there should be SynCthing in title :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers