FTBFS: dereferencing pointer to incomplete type 'EVP_PKEY {aka struct evp_pkey_st}'

Bug #1670476 reported by Raphael Groner on 2017-03-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eCryptfs
Undecided
Unassigned
Fedora
Fix Released
Undecided

Bug Description

Description of problem:
Package ecryptfs-utils fails to build from source in Fedora Rawhide.

ecryptfs_key_mod_pkcs11_helper.c: In function 'ecryptfs_pkcs11h_get_public_key':
ecryptfs_key_mod_pkcs11_helper.c:284:12: error: dereferencing pointer to incomplete type 'EVP_PKEY {aka struct evp_pkey_st}'

...
ecryptfs_key_mod_openssl.c:281:2: error: implicit declaration of function 'CRYPTO_malloc_init' [-Werror=implicit-function-declaration]

...
ecryptfs_key_mod_openssl.c:318:2: error: 'ERR_remove_state' is deprecated [-Werror=deprecated-declarations]

...
ecryptfs_key_mod_openssl.c:355:2: error: 'RSA_generate_key' is deprecated [-Werror=deprecated-declarations]

This is caused by upgrading openssl from 1:1.0.2j-1.fc26 to 1:1.1.0b-1.fc26.

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/ecryptfs-utils

Downstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=1384023

Related branches

Description of problem:
Package ecryptfs-utils fails to build from source in Fedora Rawhide.

ecryptfs_key_mod_pkcs11_helper.c: In function 'ecryptfs_pkcs11h_get_public_key':
ecryptfs_key_mod_pkcs11_helper.c:284:12: error: dereferencing pointer to incomplete type 'EVP_PKEY {aka struct evp_pkey_st}'

...
ecryptfs_key_mod_openssl.c:281:2: error: implicit declaration of function 'CRYPTO_malloc_init' [-Werror=implicit-function-declaration]

...
ecryptfs_key_mod_openssl.c:318:2: error: 'ERR_remove_state' is deprecated [-Werror=deprecated-declarations]

...
ecryptfs_key_mod_openssl.c:355:2: error: 'RSA_generate_key' is deprecated [-Werror=deprecated-declarations]

This is caused by upgrading openssl from 1:1.0.2j-1.fc26 to 1:1.1.0b-1.fc26.

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/ecryptfs-utils

Migration guide is non-existent, api changes document covers only a few things. Changes from other packages do not cover much of openssl usage in ecryptfs-utils, so we can't take inspiration from there.

tldr: I'm going to leave it for upstream or anyone who wants to work on this patch.

*** Bug 1423510 has been marked as a duplicate of this bug. ***

This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

*** Bug 1428554 has been marked as a duplicate of this bug. ***

(In reply to Michal Hlavinka from comment #1)

> tldr: I'm going to leave it for upstream or anyone who wants to work on this
> patch.

I'm interested to become a co-maintainer and I'm the maintainer of ecryptfs-simple and zulucrypt. Can you give me commit access?

> I'm interested to become a co-maintainer and I'm the maintainer of
> ecryptfs-simple and zulucrypt. Can you give me commit access?

done

Thanks! I'll update the package.

Reported to upstream.

Jelle van der Waa (jelle-vdwaa) wrote :

The following patch fixes the build with openssl 1.1.X

Jelle van der Waa (jelle-vdwaa) wrote :

I'd like to make a PR for it, but I'm not sure how I am supposed to do that.

Created attachment 1268032
patch for openssl 1.1.x

Upstream has a patch:
https://code.launchpad.net/~jelle-vdwaa/ecryptfs/ecryptfs/+merge/319746

Unfortunately, the patch provided to upstream does not work with current sources in rawhide.

Raphael Groner (projects-rg) wrote :

Your patch does not work in current Fedora rawhide.

Raphael Groner (projects-rg) wrote :

Your patch fixes ecryptfs_key_mod_openssl.c but not ecryptfs_key_mod_pkcs11_helper.c

Jason Xing (wlxing) wrote :

What version of ecryptfs did you test(i.e. trunk,108...)?

Raphael Groner (projects-rg) wrote :

We have version 111 (what should be the same as trunk in current case).

The patch for upstream got improved significantly.
This FTBFS is fixed in rawhide.

Tyler Hicks (tyhicks) wrote :

Fix committed to lp:ecryptfs as r890

Changed in ecryptfs:
status: New → Fix Committed
Changed in fedora:
importance: Unknown → Undecided
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.