Activity log for bug #1670336

Date Who What changed Old value New value Message
2017-03-06 12:13:45 Alberto Pianon bug added bug
2017-03-06 12:14:17 Alberto Pianon bug task added ubiquity (Ubuntu)
2017-03-06 12:16:33 Alberto Pianon description Description: Ubuntu Zesty Zapus (development branch) Release: 17.04 ecryptfs-utils: Installato: 111-0ubuntu4 Candidato: 111-0ubuntu4 Tabella versione: *** 111-0ubuntu4 500 500 http://it.archive.ubuntu.com/ubuntu zesty/main amd64 Packages 100 /var/lib/dpkg/status Ubuntu 17.04 uses swapfiles by default. If you select the "encrypt home folder" option when creating the main user during Ubuntu 17.04 beta1 installation (which makes Ubiquity run also the ecryptfs-setup-swap command), after installation the system hangs a lot during boot, because it fails to activate swap (output of "systemctl status swapfile.swap" says "failed to activate swap /swapfile"). If you install Ubuntu 17.04 beta1 without selecting "encrypt home folder", and only after installation you run the ecryptfs-migrate-home utility, everything works. But as soon as you try to manually setup encrypyted swap (by running ecryptfs-setup-swap), you get the same problem as above. This is due to an ecryptfs-utils bug. In particular, ecryptfs-setup-swap puts in /etc/crypttab a line like this: cryptswap1 UID=XXXXXXXX /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 (like there were a swap partition with UID=XXXXXXXX) while with a swapfile it should put the following line: cryptswap1 /swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 If you manually change that line and reboot, you get rid of the problem - before rebooting, check also that your /etc/fstab file ends with: #/swapfile none swap sw 0 0 /dev/mapper/cryptswap1 none swap sw 0 0 This bugs indirectly affects also Ubiquity, since choosing the "encrypt home folder" makes system hang a lot at boot (and when it finally starts it has no swap). ProblemType: Bug DistroRelease: Ubuntu 17.04 Package: ecryptfs-utils 111-0ubuntu4 ProcVersionSignature: Ubuntu 4.10.0-9.11-generic 4.10.0 Uname: Linux 4.10.0-9-generic x86_64 ApportVersion: 2.20.4-0ubuntu2 Architecture: amd64 CurrentDesktop: GNOME Date: Mon Mar 6 12:47:39 2017 EcryptfsInUse: Yes InstallationDate: Installed on 2017-03-05 (0 days ago) InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Alpha amd64 (20170219) ProcEnviron: TERM=xterm-256color PATH=(custom, no user) XDG_RUNTIME_DIR=<set> LANG=it_IT.UTF-8 SHELL=/bin/bash SourcePackage: ecryptfs-utils UpgradeStatus: No upgrade log present (probably fresh install) Description: Ubuntu Zesty Zapus (development branch) Release: 17.04 ecryptfs-utils:   Installato: 111-0ubuntu4   Candidato: 111-0ubuntu4   Tabella versione:  *** 111-0ubuntu4 500         500 http://it.archive.ubuntu.com/ubuntu zesty/main amd64 Packages         100 /var/lib/dpkg/status Ubuntu 17.04 uses swapfiles by default. If you select the "encrypt home folder" option when creating the main user during Ubuntu 17.04 beta1 installation (which makes Ubiquity run also the ecryptfs-setup-swap command), after installation the system hangs a lot during boot, because it fails to activate swap (output of "systemctl status swapfile.swap" says "failed to activate swap /swapfile"). If you install Ubuntu 17.04 beta1 without selecting "encrypt home folder", and only after installation you run the ecryptfs-migrate-home utility, everything works. But as soon as you try to manually setup encrypyted swap (by running ecryptfs-setup-swap), you get the same problem as above. This is due to an ecryptfs-utils bug. In particular, ecryptfs-setup-swap puts in /etc/crypttab a line like this: cryptswap1 UID=XXXXXXXX /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 (like there were a swap partition with UID=XXXXXXXX) while with a swapfile it should put the following line: cryptswap1 /swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 If you manually change that line and reboot, you get rid of the problem - before rebooting, check also that your /etc/fstab file ends with: #/swapfile none swap sw 0 0 /dev/mapper/cryptswap1 none swap sw 0 0 This bug indirectly affects also Ubiquity, since choosing the "encrypt home folder" makes system hang a lot at boot (and when it finally starts it has no swap). I tried both with Ubuntu Budgie and with Ubuntu Gnome, the problem is the same. ProblemType: Bug DistroRelease: Ubuntu 17.04 Package: ecryptfs-utils 111-0ubuntu4 ProcVersionSignature: Ubuntu 4.10.0-9.11-generic 4.10.0 Uname: Linux 4.10.0-9-generic x86_64 ApportVersion: 2.20.4-0ubuntu2 Architecture: amd64 CurrentDesktop: GNOME Date: Mon Mar 6 12:47:39 2017 EcryptfsInUse: Yes InstallationDate: Installed on 2017-03-05 (0 days ago) InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Alpha amd64 (20170219) ProcEnviron:  TERM=xterm-256color  PATH=(custom, no user)  XDG_RUNTIME_DIR=<set>  LANG=it_IT.UTF-8  SHELL=/bin/bash SourcePackage: ecryptfs-utils UpgradeStatus: No upgrade log present (probably fresh install)
2017-03-06 15:21:27 Alberto Pianon attachment removed Dependencies.txt https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1670336/+attachment/4832257/+files/Dependencies.txt
2017-03-06 15:21:35 Alberto Pianon attachment removed JournalErrors.txt https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1670336/+attachment/4832258/+files/JournalErrors.txt
2017-03-06 18:04:59 Alberto Pianon attachment added ecryptfs-setup-swap_patch_to_work_with_swapfiles.diff https://bugs.launchpad.net/ubuntu/+source/ecryptfs-utils/+bug/1670336/+attachment/4832475/+files/ecryptfs-setup-swap_patch_to_work_with_swapfiles.diff
2017-03-06 20:22:40 Alberto Pianon branch linked lp:~alberto-o/ecryptfs/swapfile-fix
2017-03-06 20:30:10 Ubuntu Foundations Team Bug Bot tags amd64 apport-bug ecryptfs ecryptfs-utils ubiquity zesty amd64 apport-bug ecryptfs ecryptfs-utils patch ubiquity zesty
2017-03-06 20:30:23 Ubuntu Foundations Team Bug Bot bug added subscriber Ubuntu Review Team
2017-03-06 23:26:00 Brian Murray ubiquity (Ubuntu): assignee Dimitri John Ledkov (xnox)
2017-03-06 23:27:05 Brian Murray nominated for series Ubuntu Zesty
2017-03-06 23:27:05 Brian Murray bug task added ubiquity (Ubuntu Zesty)
2017-03-06 23:27:05 Brian Murray bug task added ecryptfs-utils (Ubuntu Zesty)
2017-03-07 08:30:45 Alberto Pianon description Description: Ubuntu Zesty Zapus (development branch) Release: 17.04 ecryptfs-utils:   Installato: 111-0ubuntu4   Candidato: 111-0ubuntu4   Tabella versione:  *** 111-0ubuntu4 500         500 http://it.archive.ubuntu.com/ubuntu zesty/main amd64 Packages         100 /var/lib/dpkg/status Ubuntu 17.04 uses swapfiles by default. If you select the "encrypt home folder" option when creating the main user during Ubuntu 17.04 beta1 installation (which makes Ubiquity run also the ecryptfs-setup-swap command), after installation the system hangs a lot during boot, because it fails to activate swap (output of "systemctl status swapfile.swap" says "failed to activate swap /swapfile"). If you install Ubuntu 17.04 beta1 without selecting "encrypt home folder", and only after installation you run the ecryptfs-migrate-home utility, everything works. But as soon as you try to manually setup encrypyted swap (by running ecryptfs-setup-swap), you get the same problem as above. This is due to an ecryptfs-utils bug. In particular, ecryptfs-setup-swap puts in /etc/crypttab a line like this: cryptswap1 UID=XXXXXXXX /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 (like there were a swap partition with UID=XXXXXXXX) while with a swapfile it should put the following line: cryptswap1 /swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 If you manually change that line and reboot, you get rid of the problem - before rebooting, check also that your /etc/fstab file ends with: #/swapfile none swap sw 0 0 /dev/mapper/cryptswap1 none swap sw 0 0 This bug indirectly affects also Ubiquity, since choosing the "encrypt home folder" makes system hang a lot at boot (and when it finally starts it has no swap). I tried both with Ubuntu Budgie and with Ubuntu Gnome, the problem is the same. ProblemType: Bug DistroRelease: Ubuntu 17.04 Package: ecryptfs-utils 111-0ubuntu4 ProcVersionSignature: Ubuntu 4.10.0-9.11-generic 4.10.0 Uname: Linux 4.10.0-9-generic x86_64 ApportVersion: 2.20.4-0ubuntu2 Architecture: amd64 CurrentDesktop: GNOME Date: Mon Mar 6 12:47:39 2017 EcryptfsInUse: Yes InstallationDate: Installed on 2017-03-05 (0 days ago) InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Alpha amd64 (20170219) ProcEnviron:  TERM=xterm-256color  PATH=(custom, no user)  XDG_RUNTIME_DIR=<set>  LANG=it_IT.UTF-8  SHELL=/bin/bash SourcePackage: ecryptfs-utils UpgradeStatus: No upgrade log present (probably fresh install) Description: Ubuntu Zesty Zapus (development branch) Release: 17.04 ecryptfs-utils:   Installato: 111-0ubuntu4   Candidato: 111-0ubuntu4   Tabella versione:  *** 111-0ubuntu4 500         500 http://it.archive.ubuntu.com/ubuntu zesty/main amd64 Packages         100 /var/lib/dpkg/status Ubuntu 17.04 uses swapfiles by default. If you select the "encrypt home folder" option when creating the main user during Ubuntu 17.04 beta1 installation (which makes Ubiquity run also the ecryptfs-setup-swap command), after installation the system hangs a lot during boot, because it fails to activate swap (output of "systemctl status swapfile.swap" says "failed to activate swap /swapfile"). If you install Ubuntu 17.04 beta1 without selecting "encrypt home folder", and only after installation you run the ecryptfs-migrate-home utility, everything works. But as soon as you try to manually setup encrypyted swap (by running ecryptfs-setup-swap), you get the same problem as above. In particular, you get the following error when running ecryptfs-setup-swap: INFO: Setting up swap: [/swapfile] device node not found WARNING: Commented out your unencrypted swap from /etc/fstab swapon: cannot open /dev/mapper/cryptswap1: No such file or directory This is due to an ecryptfs-utils bug. In particular, ecryptfs-setup-swap puts in /etc/crypttab a line like this: cryptswap1 UID=XXXXXXXX /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 (like there were a swap partition with UID=XXXXXXXX) while with a swapfile it should put the following line: cryptswap1 /swapfile /dev/urandom swap,offset=1024,cipher=aes-xts-plain64 If you manually change that line and reboot, you get rid of the problem - before rebooting, check also that your /etc/fstab file ends with: #/swapfile none swap sw 0 0 /dev/mapper/cryptswap1 none swap sw 0 0 This bug indirectly affects also Ubiquity, because when you choose the "encrypt home folder" option during installation, ubiquity runs also ecryptfs-setup-swap; since Ubuntu 17.04 uses swapfiles by default, and ecryptfs-setup-swap does not work with swapfiles, after installation you get the system hanging a lot at boot (and when it finally starts it has no swap). I tried both with Ubuntu Budgie and with Ubuntu Gnome, the problem is the same. ProblemType: Bug DistroRelease: Ubuntu 17.04 Package: ecryptfs-utils 111-0ubuntu4 ProcVersionSignature: Ubuntu 4.10.0-9.11-generic 4.10.0 Uname: Linux 4.10.0-9-generic x86_64 ApportVersion: 2.20.4-0ubuntu2 Architecture: amd64 CurrentDesktop: GNOME Date: Mon Mar 6 12:47:39 2017 EcryptfsInUse: Yes InstallationDate: Installed on 2017-03-05 (0 days ago) InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Alpha amd64 (20170219) ProcEnviron:  TERM=xterm-256color  PATH=(custom, no user)  XDG_RUNTIME_DIR=<set>  LANG=it_IT.UTF-8  SHELL=/bin/bash SourcePackage: ecryptfs-utils UpgradeStatus: No upgrade log present (probably fresh install)
2017-03-07 12:24:49 Dimitri John Ledkov ubiquity (Ubuntu Zesty): status New Triaged
2017-03-07 12:24:51 Dimitri John Ledkov ubiquity (Ubuntu Zesty): importance Undecided High
2017-03-07 12:24:54 Dimitri John Ledkov ubiquity (Ubuntu Zesty): milestone ubuntu-17.03
2017-03-11 15:48:49 Launchpad Janitor ecryptfs-utils (Ubuntu): status New Confirmed
2017-03-11 15:48:57 Adam Dingle bug added subscriber Adam Dingle
2017-03-31 00:27:34 rahmadani ecryptfs-utils (Ubuntu Zesty): assignee rahmadani (rahmadani)
2017-04-08 02:31:05 Jeremy Bicha ecryptfs-utils (Ubuntu Zesty): assignee rahmadani (rahmadani)
2017-04-19 20:38:12 Chris Rainey bug added subscriber Chris Rainey
2017-04-26 19:14:25 Alan Reji bug task added ecryptfs
2017-06-08 20:41:06 Florent B bug added subscriber Florent B
2017-06-16 19:12:29 Tyler Hicks ecryptfs: status New Triaged
2017-06-16 19:12:34 Tyler Hicks ecryptfs: importance Undecided High
2017-06-16 19:12:36 Tyler Hicks ecryptfs: assignee Tyler Hicks (tyhicks)
2017-06-25 15:53:21 Diep Pham bug added subscriber Diep Pham
2017-07-20 21:28:58 Chris bug added subscriber Chris
2017-09-01 10:16:26 Øystein Alværvik tags amd64 apport-bug ecryptfs ecryptfs-utils patch ubiquity zesty amd64 apport-bug artful ecryptfs ecryptfs-utils patch ubiquity zesty
2017-09-01 12:27:08 Jean-Baptiste Lallement tags amd64 apport-bug artful ecryptfs ecryptfs-utils patch ubiquity zesty amd64 apport-bug artful ecryptfs ecryptfs-utils patch rls-aa-incoming ubiquity zesty
2017-09-01 12:27:16 Jean-Baptiste Lallement ubiquity (Ubuntu): milestone ubuntu-17.03 ubuntu-17.10
2017-09-01 12:27:32 Jean-Baptiste Lallement ubiquity (Ubuntu): importance High Critical
2017-09-01 12:28:57 Jean-Baptiste Lallement affects ecryptfs-utils (Ubuntu) cryptsetup (Ubuntu)
2017-09-01 12:30:12 Jean-Baptiste Lallement ubiquity (Ubuntu Zesty): milestone ubuntu-17.03 zesty-updates
2017-09-01 13:09:24 Ubuntu QA Website tags amd64 apport-bug artful ecryptfs ecryptfs-utils patch rls-aa-incoming ubiquity zesty amd64 apport-bug artful ecryptfs ecryptfs-utils iso-testing patch rls-aa-incoming ubiquity zesty
2017-09-02 09:20:02 Øystein Alværvik bug added subscriber Øystein Alværvik
2017-09-07 12:17:21 Launchpad Janitor branch linked lp:~laney/ubiquity/lp1670336
2017-09-14 15:38:48 Dimitri John Ledkov ubiquity (Ubuntu Zesty): assignee Dimitri John Ledkov (xnox)
2017-09-14 15:38:50 Dimitri John Ledkov ubiquity (Ubuntu): assignee Dimitri John Ledkov (xnox)
2017-09-14 15:39:02 Dimitri John Ledkov ubiquity (Ubuntu): assignee Iain Lane (laney)
2017-09-17 14:07:27 Christopher M. Rogers bug added subscriber Christopher M. Rogers
2017-09-25 14:29:14 Viktor Ryzhaiev bug added subscriber Viktor Ryzhaiev
2017-09-25 16:06:38 Jean-Baptiste Lallement ubiquity (Ubuntu): assignee Iain Lane (laney) Mathieu Trudel-Lapierre (cyphermox)
2017-09-27 12:34:14 Mathieu Trudel-Lapierre bug task added ecryptfs-utils (Ubuntu)
2017-09-27 12:34:37 Mathieu Trudel-Lapierre ecryptfs-utils (Ubuntu): status New In Progress
2017-09-27 12:34:45 Mathieu Trudel-Lapierre ecryptfs-utils (Ubuntu): assignee Mathieu Trudel-Lapierre (cyphermox)
2017-09-27 12:34:48 Mathieu Trudel-Lapierre ecryptfs-utils (Ubuntu): importance Undecided Critical
2017-09-27 15:59:37 Launchpad Janitor ecryptfs-utils (Ubuntu): status In Progress Fix Released
2017-09-28 12:52:02 Jean-Baptiste Lallement nominated for series Ubuntu Artful
2017-09-28 12:52:02 Jean-Baptiste Lallement bug task added cryptsetup (Ubuntu Artful)
2017-09-28 12:52:02 Jean-Baptiste Lallement bug task added ubiquity (Ubuntu Artful)
2017-09-28 12:52:02 Jean-Baptiste Lallement bug task added ecryptfs-utils (Ubuntu Artful)
2017-09-29 15:21:12 Jean-Baptiste Lallement ubiquity (Ubuntu Artful): status Triaged Fix Released
2017-09-29 15:21:30 Jean-Baptiste Lallement bug task deleted ubiquity (Ubuntu)
2017-09-29 15:21:45 Jean-Baptiste Lallement bug task deleted cryptsetup (Ubuntu)
2017-09-29 15:22:02 Jean-Baptiste Lallement ubiquity (Ubuntu Zesty): status Triaged Invalid
2017-09-29 15:22:05 Jean-Baptiste Lallement ubiquity (Ubuntu Artful): status Fix Released Invalid
2017-09-29 15:22:21 Jean-Baptiste Lallement bug task deleted ubiquity (Ubuntu Zesty)
2017-09-29 15:22:27 Jean-Baptiste Lallement bug task deleted ubiquity (Ubuntu Artful)
2017-09-29 15:22:52 Jean-Baptiste Lallement bug task deleted cryptsetup (Ubuntu Artful)
2017-09-29 15:22:58 Jean-Baptiste Lallement bug task deleted cryptsetup (Ubuntu Zesty)
2017-11-11 11:03:21 Alberto Pianon bug task added ubiquity (Ubuntu)
2017-11-18 10:48:03 Launchpad Janitor ubiquity (Ubuntu): status New Confirmed
2017-11-18 10:48:03 Launchpad Janitor ecryptfs-utils (Ubuntu Zesty): status New Confirmed
2017-12-30 02:07:25 Markus Birth bug added subscriber Markus Birth
2018-01-12 21:20:01 Carsten Fuchs bug added subscriber Carsten Fuchs
2018-04-14 05:41:33 Christoph Hahn bug added subscriber Christoph Hahn