ecryptfs-recover-private reports ecryptfs mounted read-only although it is mounted read-write using --rw

Bug #1028923 reported by Bernhard on 2012-07-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eCryptfs
Undecided
Tyler Hicks

Bug Description

When invoking "ecryptfs-recover-private --rw /some/directory/.Private" and passing the correct mount password, the "SUCCESS!" message reads:

"INFO: Success! Private data mounted read-only at [/tmp/ecryptfs.XXXXXXXX]."

However, the encrypted home directory is mounted read-write as requested by the "--rw" switch. The message should make it clear that the encrypted home directory has been mounted read-write when the "--rw" swith has been activated.

Please also note https://bugs.launchpad.net/ecryptfs/+bug/1004082 when using the command as given above.

Bernhard (schlimmchen) on 2012-07-25
description: updated
Changed in ecryptfs:
status: New → Confirmed

Confirmed, the message should depend on the options given to it, but since the options are parsed by the script then passed on to the mount.ecryptfs call this is an easy fix.

Tyler Hicks (tyhicks) wrote :

Thanks for the patch, Wesley.

I noticed that the mount command was incorrectly changed in your patch, so I didn't end up using it. I simply dropped the read-only part of the success message so that is always says "Success! Private data mounted at [$tmpdir]."

Changed in ecryptfs:
assignee: nobody → Tyler Hicks (tyhicks)
status: Confirmed → Fix Committed
Daniel Kulesz (kuleszdl) wrote :

Experienced the same problem yesterday on an up-to-date Ubuntu 12.04 installation. I didn't try the attached patch, but I hope this issue can be resolved soon.

Nevertheless, I am against a general, less-informative message without the case evaluation. I think that the user shall be notified in case the mount was only read-only (when the parameter --rw is not supplied), because most people would assume that the mount is rw...

Changed in ecryptfs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers