15.04: Full disk encryption with home dir encryption: have to enter FDE password twice

Bug #1447881 reported by gravy45 on 2015-04-24
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Plymouth
New
Undecided
Unassigned
ecryptfs-utils
New
Undecided
Unassigned

Bug Description

Noticed that having a full disk encryption install with home directory encryption requires entering the full disk encryption password twice: once to unlock the disk, and again to unlock the 'swap'. Did not configure a separate swap, this is the default swap provided.

System: Kernel: 3.19.0-15-generic x86_64 (64 bit gcc: 4.9.2)
Desktop: MATE 1.8.2 (Gtk 3.14.12-0ubuntu2)
Distro: Ubuntu 15.04 vivid
Graphics: Card: Advanced Micro Devices [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] bus-ID: 01:00.0
           Display Server: X.Org 1.17.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1200@60.0hz
           GLX Renderer: Gallium 0.4 on AMD CEDAR GLX Version: 3.0 Mesa 10.5.2 Direct Rendering: Yes

Confirmed it occurs on a physical machine (above hardware), also get the following bug:
https://bugs.launchpad.net/ubuntu/vivid/+source/linux/+bug/1359689

In Virtualbox 4.3.26, the preceding bug does not appear, but two passwords must be entered (please see attached Virtualbox screenshot). Also confirmed on Ubuntu with unity desktop.

gravy45 (gravy45) wrote :

plymouth-debug.log

no longer affects: ubuntu-mate
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers