Numerous applications have focus issues after emerging from a screensaver or suspend

Bug #438868 reported by Eric Appleman
980
This bug affects 196 people
Affects Status Importance Assigned to Milestone
Compiz
Fix Released
Medium
Eclipse
Invalid
Medium
Mozilla Firefox
Invalid
Medium
Nominated for 3.6 by papukaija
Nominated for Trunk by papukaija
kile
Confirmed
Undecided
Unassigned
compiz (Ubuntu)
Fix Released
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Lucid
Fix Released
Undecided
Unassigned
Maverick
Fix Released
Undecided
Unassigned
firefox (Ubuntu)
Invalid
Low
Unassigned
Declined for Karmic by Sebastien Bacher
Lucid
Invalid
Undecided
Unassigned
Maverick
Invalid
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Invalid
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Lucid
Invalid
Undecided
Unassigned
Maverick
Invalid
Undecided
Unassigned
firefox-3.5 (Ubuntu)
Invalid
Medium
Unassigned
Declined for Karmic by Sebastien Bacher
Lucid
Invalid
Undecided
Unassigned
Maverick
Invalid
Undecided
Unassigned
indicator-session (Ubuntu)
Invalid
Undecided
Unassigned
Declined for Karmic by Sebastien Bacher
Lucid
Invalid
Undecided
Unassigned
Maverick
Invalid
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.5

For the past few weeks, builds of Firefox 3.5, 3.6, and 3.7 have exhibited a behavior where the autocomplete of the so-called awesome bar will only work sporadically.

There are some times where the autocomplete will not work at all and other times when it will appear for a few milliseconds after typing a letter before disappearing.

I haven't been able to pin-point what causes this, but I have found that restarting the browser resolves the issue until it occurs again.

This doesn't happen very often, but at least a few times each day.

Reproducible: Sometimes
==========
SRU:

This bug affects all users using compiz and Firefox.Patch is taken from the compiz 0.8.8 branch from upstream cgit. Patch has also been port-forwarded to 0.9 branch and is available in latest Natty compiz package.

TestCase:

With current stock Ubuntu compiz packages:
1- When Firefox is open; allow screensaver to kick-in (or resume from suspend) and then start using Firefox
2- Notice Awesome bar does not auto-complete with suggestions(firefox 3.6) and bookmarks menu, context menu are completely unusable(Firefox 4).

Install compiz package from -proposed:
Awesome bar, Context menu, bookmarks menus all work normally

Regression potential:
None ( maybe users notice more awesomeness of Firefox 4?)

==========
SRU packages:
For Ubuntu 10.10 : Maverick-proposed > Compiz 1:0.8.6-0ubuntu9.2
For Ubuntu 10.04 : Lucid-proposed > Compiz 1:0.8.4-0ubuntu15.3

==========
Compiz commit which seems to fix the issue for Firefox:

http://cgit.compiz.org/compiz/core/commit/?id=30a92d8a060d79181a28840d7c66428ef431200c

==========

Revision history for this message
In , Mak77 (mak77) wrote :

is this in safe mode? do you have any add-on that could interfere with it?

Revision history for this message
In , Twalker (twalker) wrote :

reporter, please respond to the safe mode question.

Revision history for this message
In , Llivinglarge (llivinglarge) wrote :

Happens in safe mode and even when no add-ons are installed.

Also affects 3.5.3 and 3.7a1.

Revision history for this message
In , Llivinglarge (llivinglarge) wrote :

Also, I can confirm that this happens on a fresh Ubuntu Jaunty or Karmic install.

Revision history for this message
Eric Appleman (erappleman) wrote : Address bar autocomplete doesn't always work

Binary package hint: firefox-3.5

For the past few weeks, builds of Firefox 3.5, 3.6, and 3.7 have exhibited a behavior where the autocomplete of the so-called awesome bar will only work sporadically.

There are some times where the autocomplete will not work at all and other times when it will appear for a few milliseconds after typing a letter before disappearing.

I haven't been able to pin-point what causes this, but I have found that restarting the browser resolves the issue until it occurs again.

This doesn't happen very often, but at least a few times each day.

Reproducible: Sometimes

ProblemType: Bug
Architecture: i386
CheckboxSubmission: b8398b21075a3a8723b2ba20478c4f9e
CheckboxSystem: 703a6ca1eefae989daaf40c6bb6aa94a
Date: Tue Sep 29 13:34:19 2009
DistroRelease: Ubuntu 9.10
Package: firefox 3.5.3+build1+nobinonly-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-genusername
SourcePackage: firefox-3.5
Uname: Linux 2.6.31-11-generic i686

Revision history for this message
Eric Appleman (erappleman) wrote :
Changed in firefox:
status: Unknown → New
Revision history for this message
In , Mozilla-bugs-micahscomputing (mozilla-bugs-micahscomputing) wrote :
Revision history for this message
In , Llivinglarge (llivinglarge) wrote :

I've also noticed that if I leave my laptop on overnight with the browser open, this bug will occur without fail.

Revision history for this message
In , Llivinglarge (llivinglarge) wrote :

I forgot to mention that my machine doesn't enter hibernation or suspend and this happens both with and without the screensaver being active.

Revision history for this message
Micah Gersten (micahg) wrote : Re: Address bar autocomplete doesn't always work

We'll see what upstream has to say...

Changed in firefox-3.5 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
XeHK (berseeker) wrote :

It seems that i have the same bugю Sometime Address bar not rolled-down, and autocomplete refuses to work. When i rightclick on page and menu appeared, then address bar works perfectly for some time, but this bug returns few times in a day. Noticed this bug after upgrade from Interpid to Jaunty. It appeared in Firefox 3.0 and 3.5

Revision history for this message
Alan Pater (alan-pater) wrote :

This bug does not affect Firefox 3.5 on Windows. I have seen it on both Ubuntu 9.04 and now on the beta of 9.10.

It usually happens to me when I resume from suspend and have left Firefox running. I then close and re-open Firefox, and the address bar then responds.

Revision history for this message
Alexander Sack (asac) wrote :

eric, can you try to build xulrunner without system sqlite? ask in channel how to do that ;).

Revision history for this message
In , Llivinglarge (llivinglarge) wrote :

Right-clicking on a webpage seems to fix the autocomplete until it acts up again.
I think this may be a focus issue.

Revision history for this message
Alexander Sack (asac) wrote : Re: Address bar autocomplete doesn't always work

eric, any chance to do do this test? would be great as we dont have much time for release ;)

Revision history for this message
Eric Appleman (erappleman) wrote :

Right-clicking on a webpage seems to fix the autocomplete until it acts up again.

I think this may be a focus issue.

As for the xulrunner build, I may tackle that tonight.

Revision history for this message
Alan Pater (alan-pater) wrote :

re: right-clicking

Yeah, that's weird. Right-clicking does two things. It brings up a context menu and it clears the address bar which then changes to "Search Bookmarks and History".

With the address bar working correctly, right clicking does only one thing, it brings up the context menu, it does not clear the address bar.

Manually clearing the contents of the address when it is stuck also restores normal functionality, though a quick right then left click is faster.

Revision history for this message
RedG (tomas-redgoblin) wrote :

I also have this issue.
It's seems like it happens after I leave firefox running and the screensaver starts.
To "correct" it I just left-click the icon to the left of the address-bar twice, I don't remember the name of that icon, but for launchpad.net it's a white square with the letter lp in it. favicon?? The first click gives me a security message, the second removes that message. Then it works for a while again.

But I while back I turned the screensaver off and only use powermanager - turn off screen after n minutes. Since then I don't know if I ever have had that problem again.

Revision history for this message
Chris Hollenbeck (chris-hollenbeck) wrote :

This also happens to me. I have compositing enabled and don't use suspend or hibernate. I do, however, constantly save my sessions. It seems to work fine when I start up the browser and is broken right now. I'll try to keep an eye on it and see if the screensaver is related on my computer. I am running the latest Karmic.

Revision history for this message
In , Heather Arthur (harthur) wrote :

After watching the behavior a bit, it's really starting to feel to me like this is an issue with the popup. I sometimes see a brief flash of the popup with what I believe is the correct autocomplete information. Also sometimes I see no popup, but the cursor changing from the input cursor to the default cursor for a split second. I think the popup is closing as soon as it's opened.

Changed in firefox:
status: New → Confirmed
Revision history for this message
Jonas (jonas-f-henriksen) wrote : Re: Address bar autocomplete doesn't always work

I also have this issue on jaunty, firefox 3.0.14. Happens randomly, but seems to always happen if I lock the screen with <ctrl>-<alt>-L. Right-clicking does not solve the problem for me, I have to restart the browser.

Revision history for this message
In , Alexander Sack (asac) wrote :

Is this related to compiz in some way?

Revision history for this message
Chris Hollenbeck (chris-hollenbeck) wrote : Re: Address bar autocomplete doesn't always work

This happened again this evening. I left it alone for about 6 hours and have screen blanking enabled. The address bar was working before I left and was broken again when I returned. It looks like it is trying to show up, as I can see the list display for a fraction of a second, but it disappears after that.

Revision history for this message
Alexander Sack (asac) wrote :

Is this related to compiz in some way?

Revision history for this message
John Vivirito (gnomefreak) wrote :

i am unable to reproduce this in our daily builds of 3.5 3.6 3.7. I do not use compiz and i do use nvidia-glx-185
nvidiai version:
185.18.36-0ubuntu7

Revision history for this message
In , Llivinglarge (llivinglarge) wrote :

Possibly related to Compiz.

I left my laptop on all night with Compiz disabled and the screensaver didn't trigger the bug this morning.

Revision history for this message
Eric Appleman (erappleman) wrote : Re: Address bar autocomplete doesn't always work

Possibly related to Compiz.

I left my laptop on all night with Compiz disabled and the screensaver didn't trigger the bug this morning.

Revision history for this message
Jens Janssen (jayjay) wrote :

Same problem here with radeon-driver & Compiz enabled.

Revision history for this message
In , Sdwilsh (sdwilsh) wrote :

*** Bug 508463 has been marked as a duplicate of this bug. ***

Revision history for this message
In , daviddahl (ddahl) wrote :

I can confirm this bug as well with Compiz turned off. It is hard to reproduce on command though.

Revision history for this message
In , Mozilla-bigwillystyle42 (mozilla-bigwillystyle42) wrote :

I also hit this bug occasionally; it seems to occur more frequently after I've been away from my machine for a while and had the screensaver kick in. Is there any sort of debug information/output that could be checked? Or anything we could try while in that state that might provide more information?

Revision history for this message
In , cb474 (cb474) wrote :

I'm also having this problem, on 3.5.3.

Revision history for this message
Anonym25712 (anonym25712) wrote : Re: Address bar autocomplete doesn't always work

I have experienced this for quite some time now, I even think it also happened with previous versions of Firefox. This is very frustrating, as there's no way to get the auto completion back without restarting the browser.

Revision history for this message
cyba (marcus-kempe) wrote :

I've been having this problem in FF 3.0 and now also in 3.5 with the installation of 9.10.

I also use Compiz.

Despite what is said in earlier posts, for me it is possible to get autocomplete back without restarting the browser. If I switch to another program for a while (alt+tab), and then go back to FF, it will work again (randomly).

Revision history for this message
BlackSir (blacksir) wrote :

I'm often have this bug after backing from a screensaver (both in Jaunty and Karmic). Minimize/maximize FF window always makes awesomebar works again.

Revision history for this message
In , Heather Arthur (harthur) wrote :

just confirming that this also affects the search box, as one might expect.

Revision history for this message
In , Sdwilsh (sdwilsh) wrote :

Alright, so given comment 16 this is likely an AutoComplete bug. Dietrich was seeing something like this today I think too.

Revision history for this message
In , cb474 (cb474) wrote :

Still see the problem in 3.5.4.

Revision history for this message
Chris Miller (beretta627) wrote : Re: Address bar autocomplete doesn't always work

Same problem here. Both Jaunty+Karmic with compiz enabled, ATI graphics card. seems to occur mostly (but still feeling random) when I'm away from the computer or unfocused from FF. Happened first in Shiretoko, and then went back to Firefox 3.5 and the same problem reoccurs. doubleclicking the favicon to the left seems to re-enable, or a browser restart.

Revision history for this message
John Green (john-thegreens) wrote :

This has been happening to me for sometime in both jaunty and karmic so firefox 3 and 3.5. It only happens when coming back to the desktop after the screensaver has been running but then again not every time so I can't make it happen. I can't type in the address bar at all. I type one letter and it is immediately selected so that when you type another it is overwritten. I have compiz running, Nvidia graphics card. 64-bit.If I switch to another desktop (ctrl-alt-right) and back again(ctrl-alt-left) then I can type normally. As I said this has been happening on and off for at least 6 months and though I get the impression it is compiz related I've never seen it happen in any other app than firefox.

172 comments hidden view all 226 comments
Revision history for this message
In , 5-seter-r (5-seter-r) wrote :

Build Identifier: M20090917-0800

When waking up after having gone into screen saver mode, Eclipse is unresponsive
to keystrokes. Mouse still works.

Workaround 1:
- switch workspace and back. I mean X workspaces, not Eclipse workspaces. Eg. CTRL-ALT-RIGHTARROW followed by CTRL-ALT_LEFTARROW.

Workaround 2:
- restart Eclipse

Reproducible: Always

Steps to Reproduce:
1. Start Eclipse and work a bit, then leave it alone until the screen saver kicks in (simple screen fading to black in my case). Make sure you have eg. an editor open (in my case a java file, but I don't think it matters).
2. Wake it up again eg. by moving the mouse
3. Try typing: it doesn't work!

Revision history for this message
In , 5-seter-r (5-seter-r) wrote :

Some additional system info:
- Ubuntu 9.10 64bit (x86_64)

Revision history for this message
In , Francis Upton (francisu) wrote :

Might this be related to the GTK changes with Karmic (I'm on Jaunty and have no trouble).

http://blog.export.be/2009/10/fixing-eclipse-for-ubuntu-karmic-koala-9-10/
https://bugs.eclipse.org/bugs/show_bug.cgi?id=287307

You might try the workaround suggested in the blog posting.

Revision history for this message
In , 5-seter-r (5-seter-r) wrote :

I'm pretty confident it's not related to the GTK changes. I have the GDK_NATIVE_WINDOWS workaround applied for over a month now, but that didn't help this issue at all. Moreover, I already had this problem when I was still on Jaunty and even before that. It's maybe x86_64 related?

Revision history for this message
In , Francis Upton (francisu) wrote :

(In reply to comment #3)
>. It's maybe x86_64 related?
I'm on X86_64. Have you tried a non-Eclipse application under the same circumstances?

Revision history for this message
In , Ob1-eclipse (ob1-eclipse) wrote :

Moving to SWT for comments.

summary: - Address bar autocomplete doesn't always work
+ Address bar autocomplete and search bar autocomplete doesn't work after
+ emerging from a screensaver or suspend
summary: - Address bar autocomplete and search bar autocomplete doesn't work after
- emerging from a screensaver or suspend
+ Address bar autocomplete and search bar autocomplete doesn't always work
+ after emerging from a screensaver or suspend
Changed in firefox-3.0 (Ubuntu):
status: New → Invalid
Changed in firefox-3.5 (Ubuntu):
status: Triaged → Invalid
Changed in firefox (Ubuntu):
status: New → Triaged
Revision history for this message
In , Samuelwestbrook (samuelwestbrook) wrote :

I'm observing this running on Ubuntu 9.1 and Dell Optiplex 755. All updates to OS and Eclipse have been applied. The problem also occurs if "lcok screen" is chosen and then the screen unlocked for reuse. Clicking to another progam and back makes Eclipse responsive again. No other applications have shown the same effect.

summary: - Address bar autocomplete and search bar autocomplete doesn't always work
- after emerging from a screensaver or suspend
+ Numerous applications have focus issues after emerging from a
+ screensaver or suspend
Omer Akram (om26er)
affects: indicator-applet (Ubuntu) → indicator-session (Ubuntu)
Revision history for this message
In , Remy Chi Jian Suen (remy-suen) wrote :

*** Bug 315010 has been marked as a duplicate of this bug. ***

Changed in indicator-session (Ubuntu):
status: New → Invalid
Changed in firefox (Ubuntu):
importance: Undecided → Low
Revision history for this message
In , Pinnamur (pinnamur) wrote :

*** Bug 318064 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Mikhail-zabaluev (mikhail-zabaluev) wrote :

(In reply to comment #6)
> No other applications have shown the same
> effect.

Firefox has a similar problem, which appeared at the same Ubuntu upgrade:
https://bugzilla.mozilla.org/show_bug.cgi?id=507269

Revision history for this message
In , 5-seter-r (5-seter-r) wrote :

It is somehow related to the compiz window manager. When using metacity instead of compiz the problem seems to be gone.

papukaija (papukaija)
tags: added: metabug
Changed in firefox:
importance: Unknown → Medium
Changed in kile:
status: New → Confirmed
Changed in eclipse:
status: New → Confirmed
Revision history for this message
In , Remy Chi Jian Suen (remy-suen) wrote :

*** Bug 329600 has been marked as a duplicate of this bug. ***

Changed in eclipse:
importance: Undecided → Unknown
status: Confirmed → Unknown
Revision history for this message
In , Mikhail-zabaluev (mikhail-zabaluev) wrote :

As tracked on Ubuntu Launchpad: https://bugs.launchpad.net/eclipse/+bug/438868

Changed in compiz:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in firefox:
status: Confirmed → Invalid
Vish (vish)
Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in firefox (Ubuntu):
status: Triaged → Invalid
Vish (vish)
description: updated
Vish (vish)
Changed in firefox-3.0 (Ubuntu Lucid):
status: New → Invalid
Changed in firefox-3.5 (Ubuntu Maverick):
status: New → Invalid
Changed in firefox-3.5 (Ubuntu Lucid):
status: New → Invalid
Changed in firefox-3.0 (Ubuntu Maverick):
status: New → Invalid
Changed in firefox (Ubuntu Lucid):
status: New → Invalid
Changed in firefox (Ubuntu Maverick):
status: New → Invalid
Changed in indicator-session (Ubuntu Lucid):
status: New → Invalid
Changed in indicator-session (Ubuntu Maverick):
status: New → Invalid
Vish (vish)
Changed in compiz (Ubuntu):
status: Triaged → Fix Released
Changed in compiz (Ubuntu Lucid):
status: New → Triaged
Changed in compiz (Ubuntu Maverick):
status: New → Triaged
Changed in compiz (Ubuntu Lucid):
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in compiz (Ubuntu Maverick):
assignee: nobody → Chris Coulson (chrisccoulson)
Vish (vish)
description: updated
Changed in compiz (Ubuntu Lucid):
assignee: Chris Coulson (chrisccoulson) → nobody
Changed in compiz (Ubuntu Maverick):
assignee: Chris Coulson (chrisccoulson) → nobody
Paul Sladen (sladen)
Changed in compiz (Ubuntu Lucid):
milestone: none → lucid-updates
Changed in compiz (Ubuntu Maverick):
milestone: none → maverick-updates
Martin Pitt (pitti)
Changed in compiz (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in compiz (Ubuntu Lucid):
status: Triaged → Fix Committed
Changed in compiz:
status: Confirmed → Fix Released
tags: added: verification-done
removed: verification-needed
37 comments hidden view all 226 comments
Revision history for this message
SimonWerner (simonwerner) wrote :

It works here too on Lucid. Thanks for the effort, it's been a long time.

Revision history for this message
Corey B. (cbodendein) wrote :

The compiz fix in proposed works for me too on Lucid using Firefox 4 from the mozillateam ppa.

Revision history for this message
Bob (bbrazie) wrote :

What is the name(s) of the package that shows in the list of proposed in the window of update manager in Ubuntu 10.10?

Revision history for this message
Vish (vish) wrote :

@Bob:
For Ubuntu 10.10 : Maverick-proposed > Compiz 1:0.8.6-0ubuntu9.2
For Ubuntu 10.04 : Lucid-proposed > Compiz 1:0.8.4-0ubuntu15.3

description: updated
Revision history for this message
Bob (bbrazie) wrote :

Thank you. Thank you all!

Bob.

Revision history for this message
Bob (bbrazie) wrote :

In the proposed list I do not find a file to install named (Compiz 1:0.8.6-0ubuntu9.2) for my Ubuntu 10.10 machine.

Thank you.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.4-0ubuntu15.3

---------------
compiz (1:0.8.4-0ubuntu15.3) lucid-proposed; urgency=low

  * Upstream patch, 438868_Dont-grant-override_redirect-windows-focus,
    from 0.8.8 branch; (LP: #438868)
 -- K Vishnoo Charan Reddy <email address hidden> Sat, 02 Apr 2011 21:34:58 +0530

Changed in compiz (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.6-0ubuntu9.2

---------------
compiz (1:0.8.6-0ubuntu9.2) maverick-proposed; urgency=low

  * Upstream patch, 438868_Dont-grant-override_redirect-windows-focus,
    from 0.8.8 branch; (LP: #438868)
 -- K Vishnoo Charan Reddy <email address hidden> Sat, 02 Apr 2011 21:34:58 +0530

Changed in compiz (Ubuntu Maverick):
status: Fix Committed → Fix Released
Revision history for this message
jevgtv (tugevus) wrote : Re: [Bug 438868] Re: Numerous applications have focus issues after emerging from a screensaver or suspend

I have compiz - 1:0.8.4-0ubuntu15.3 already, but the problem still exist.

On 12/04/11 13:20, Launchpad Bug Tracker wrote:
> This bug was fixed in the package compiz - 1:0.8.4-0ubuntu15.3
>
> ---------------
> compiz (1:0.8.4-0ubuntu15.3) lucid-proposed; urgency=low
>
> * Upstream patch, 438868_Dont-grant-override_redirect-windows-focus,
> from 0.8.8 branch; (LP: #438868)
> -- K Vishnoo Charan Reddy<email address hidden> Sat, 02 Apr 2011 21:34:58 +0530
>
> ** Changed in: compiz (Ubuntu Lucid)
> Status: Fix Committed => Fix Released
>
> ** Changed in: compiz (Ubuntu Maverick)
> Status: Fix Committed => Fix Released
>

Revision history for this message
Vark (vark) wrote :

I found this through searching - as I have a site that uses a lot of dropdowns and right-click menus - and they all fail in Firefox4 after a screensaver (in my case simple blanking) runs. This patch does not fix this issue for me.

Ubuntu 10.10
Firefox 4 (from PPA)

It does appear that tabbing away from FF4 and back again does seem to resolve it for me, as suggested above.

Revision history for this message
Paul Swartz (paulswartz) wrote :

compiz 1:0.8.6-0ubuntu9.2 (maverick) now has a broken click-to-raise for me. Clicking on Google Chrome (with or without the system titlebars) no longer raises it above other windows. Downgrading to 1:0.8.6-0ubuntu9.1 resolves the issue, so the patch causes an additional issue for me.

Revision history for this message
Christoph Buchner (bilderbuchi) wrote :

You should report this as a separate bug.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Has anyone noticed this seems to have regressed again in Natty? Unless it's just my machine...

Revision history for this message
enb (elitenoobboy) wrote :

"Has anyone noticed this seems to have regressed again in Natty? Unless it's just my machine..."

Natty uses a newer version of compiz (.9 something) that isn't affected by this. The bug you are experiencing is probably unrelated to this one.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

"Natty uses a newer version of compiz (.9 something) that isn't affected by this"

Hmmm, I know that already. It isn't affected because it has the same patch we just deployed to Lucid and Maverick. However, this has started happening again in Natty, so I'm not sure you can say it's unrelated to this one.

Revision history for this message
Romano Giannetti (romano-giannetti) wrote :

I noticed it too on Natty. After a screen-lock, the address bar in some "new tab" windows do not receive keyboard focus (I have focus-follow-mouse, but even clicking on the address is not useful).

Is quite difficult to reproduce, but it's easier if you have various firefox windows (each with several tab) in different viewports. Doing a bit of iconize-hide-unmaximize and viewport switching usually triggers the problem.

I noticed this only recently. Maybe a firefox-5 update regression?

Revision history for this message
SRoesgen (s-roesgen) wrote :

Yep,

noticed the return of the problems, too. Firefox 5.0 very often loses keyboard focus if I have more than one Firefox window opened (no matter how many tabs I opened within the windows).

Interestingly, the problems are now more grave than before. When I lose the keyboard focus, the old tricks do not work anymore. When I change to another virtual desktop/workspace and then change back to the one on which I have opened the window the problem still exists and I still have no focus.

Btw.: I noticed a second before that I do not only lose the keyboard focus, but also I cannot click on any flash video (like, for instance, those on youtube). There is no reaction to mouseclicks.

There are only two possible workaround to regain keyboard focus (or a correctly working Firefox Window ):

1) Close Firefox completely and then reopen the windows. So I let sessionmanger handle this and I have to hope that all windows, on which I had been working, will open correctly.

2) The second solution is somewhat strange. I can open a new Firefox window, in addition to those which I have already opened. This new window will -- certainly -- get the keyboard focus. But then I can change to the original Firefox window which displayed the focus issues and there the keyboard focus works again as well.

It should be said that in all cases I recently encountered I lost the focus in ONE of the Firefox windows not in all of them. So I was able to type into window A (no matter in which tab is was working) but somehow Firefox windows B lost its keyboard focus and later one it won't regain the focus.

Revision history for this message
diego (marcodiegomesquita) wrote :

SRoesgen (s-roesgen) , can you check if it is related to flash? I remember having many focus issues if firefox was displaying a flash animation.

Revision history for this message
sommerkom (sommerkom) wrote :

I can confirm this bug on 11.10 with unity, firefox 8. It occurs rather frequently, playing around with window focus temporarily fixes the problem until it reappears some time later. I don't need to suspend or turn on the screen saver to have this bug occur.

I suffered from this bug on Maverick, however, it disappeared for a couple of days after I updated to Oneiric. Now it's there again, not sure what triggered it. I can also confirm that it often starts with the URL drop down box flickering for a fraction of a second before vanishing altogether. Auto-complete within the browser is also affected. I wonder if I caused this bug by changing some settings in CSSM since nobody has reported anything here for Oneiric.

Revision history for this message
Simon Marlow (simonmar) wrote :

Yes, still happening with 11.10. I'm in the habit of Alt-Tabbing twice after resuming from suspend now.

I don't think this is related to flash - I have flashblock installed and rarely use flash.

Revision history for this message
Maarten Kossen (mpkossen) wrote :

Indeed, still happening. Could this be a compiz bug once more?

Revision history for this message
sommerkom (sommerkom) wrote :

Could somebody please reopen this bug? It's obviously not fixed in 11.10 and it does affect the user experience. For me, the focus issues do not only occur after resuming from suspend/hibernate but also after switching back from other applications. In addition, accessing the dash via super key doesn't work reliably in firefox, presumably due to the same bug.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Please make a new bug report with precise steps to reproduce the problem.

Revision history for this message
In , Koosha Khajeh Moogahi (koosha) wrote :

I'm using Debian Squeeze and I have encountered this bug too. When Firefox is focused and after I re-login to gnome (after the minimum allowed idle time has passed) the autocomplete of address bar doesn't work. I have to minimize and then maximize Firefox to make the autocomplete work.

Revision history for this message
diego (marcodiegomesquita) wrote :

Could no longer reproduce it in 12.04. I'd say it is fixed.

Revision history for this message
EA (mceric) wrote :

Still happens in Ubuntu 12.04 (and 11.04) for me, triggered whenever I window-shade for example Thunderbird or Firefox. Minimizing and restoring the window helps. According to other messages here, screensaver and thus standby also always triggers it. I also confirm that focusing another window for a moment helps.

The symptom of the bug is that in Firefox URL autocompletion, the list of suggestions immediately vanishes when it is about to show up and that all sorts of menus vanish at the moment when I try to move the mouse over them. For example I click on FILE, a menu shows up, I move the mouse to the menu, it vanishes. VERY frustrating. Sometimes using hotkeys helps, but by far not everything works without mouse. According to this bug discussion, the problem might be the Z window stacking of compiz messing up and getting fixed by being reset using the minimize-restore or focus-something-else workarounds.

This might also be related to: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/968332

13 comments hidden view all 226 comments
Revision history for this message
In , Ericwill (ericwill) wrote :

I cannot reproduce this issue. Given the age of the bug, I am going to close this. Please file a new bug against Oxygen if the issue pops up again.

Changed in eclipse:
importance: Unknown → Medium
status: Unknown → Invalid
Displaying first 40 and last 40 comments. View all 226 comments or add a comment.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.