defect: "Attribute(description) does not pass the type constraint"

Bug #485692 reported by Eric Hammond
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ec2-consistent-snapshot
Fix Released
Medium
Eric Hammond

Bug Description

As pointed out here:

  http://groups.google.com/group/ec2ubuntu/browse_thread/thread/7dfcc9e7264882eb

This error message happens regularly now:

ec2-consistent-snapshot: ERROR: create_snapshot: Attribute
(description) does not pass the type constraint because: Validation
failed for 'Maybe[Str]' failed with value HASH(0x1f89d28) at (eval
219) line 68

In the above thread, John Shields points out a potential workaround.

Revision history for this message
Eric Hammond (esh) wrote :

This has been resolved in version 0.1-8 now available on the Alestic PPA.

Changed in ec2-consistent-snapshot:
status: Confirmed → Fix Released
Revision history for this message
Nicholas Sherlock (n-sherlock) wrote :

This problem seems to still exist:

 ec2-consistent-snapshot --aws-access-key-id xxxxxxxxxxxxxxxxxx --aws-secret-access-key xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx --description "DB server $(date +'%Y-%m-%d %H:%M:%S')" --xfs-filesystem /db --mysql --mysql-host localhost --mysql-username root --mysql-password xxxxxx vol-xxxxxx vol-xxxxxx vol-xxxxxx vol-xxxxxx

ec2-consistent-snapshot: ERROR: create_snapshot: Attribute (progress) does not pass the type constraint because: Validation failed for 'Str' failed with value undef at /usr/local/share/perl/5.10.0/Net/Amazon/EC2.pm line 828
        Net::Amazon::EC2::create_snapshot(undef, 'VolumeId', 'vol-xxxxxx', 'Description', 'DB server 2010-01-10 09:27:29') called at /usr/bin/ec2-consistent-snapshot line 136
        eval {...} called at /usr/bin/ec2-consistent-snapshot line 134
        main::ebs_snapshot('ARRAY(0x2d36bf8)', undef, 'DB server 2010-01-10 09:27:29') called at /usr/bin/ec2-consistent-snapshot line 90

It does take a snapshot of the first volume, but only the first volume.

Installed versions:

Net::Amazon::EC2 is up to date (0.12).

wajig status ec2-consistent-snapshot
Package Installed Previous Now State
=======================-===============-===============-===============-=====
ec2-consistent-snapshot 0.2 N/A N/A install

Revision history for this message
Eric Hammond (esh) wrote :

This looks like a completely different bug since the error is "Attribute (progress) does not[...]" instead of "Attribute (description) does not[...]".

You may submit a new bug report, but my suspicion is that it is an issue in side of Net::Amazon::EC2 and not in ec2-consistent-snapshot.

In the Net/Amazon/EC2/Snapshot.pm on your system, try changing this line:

  has 'progress' => ( is => 'ro', isa => 'Str', required => 1 );

to this line:

  has 'progress' => ( is => 'ro', isa => 'Maybe[Str]', required => 0 );

Revision history for this message
Eric Hammond (esh) wrote :

Nicholas: Just chatted with Jeff Kim. He'll be pushing out a new version of Net::Amazon::EC2 to fix the "Attribute (progress)" problem you are seeing. Thanks for bringing this up. (Again, it's separate from bug 485692 here, so this is remaining "fix released").

Revision history for this message
Nicholas Sherlock (n-sherlock) wrote :

Whoops, didn't notice that difference :). Thanks for the update.

Revision history for this message
Jeff Kim (jkim) wrote :

Just as an update to this I released Net::Amazon::EC2 version 0.13 yesterday with the fix to the progress attribute bug in place.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers