Dependencies for install wrong

Bug #403978 reported by Chris Puttick on 2009-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
EasyCrypt
Undecided
Unassigned

Bug Description

Installing easycrypt on Kubuntu (or to be exact, not after the following occurred). Dependencies seem wrong, not to say terribly unlikely for a simple GUI wrapper...

sudo apt-get install easycrypt
[sudo] password for:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  esound-clients esound-common gamin gnome-icon-theme gnome-keyring
  gnome-media gnome-media-common gnome-mime-data gnome-mount
  gstreamer0.10-alsa gstreamer0.10-plugins-base gstreamer0.10-plugins-good
  gstreamer0.10-x gvfs gvfs-backends libaudiofile0 libavahi-glib1
  libavc1394-0 libbonobo2-0 libbonobo2-common libbonoboui2-0
  libbonoboui2-common libcamel1.2-14 libcanberra-gtk-module libcanberra-gtk0
  libcanberra0 libcdio-cdda0 libcdio-paranoia0 libcdio7 libcroco3 libdv4
  libebook1.2-9 libecal1.2-7 libedataserver1.2-11 libesd-alsa0 libevdocument1
  libevview1 libgail-common libgail18 libgamin0 libgcr0 libgda3-3 libgda3-bin
  libgda3-common libgdl-1-0 libgdl-1-common libgksu2-0 libglade2-0
  libgnome-desktop-2-11 libgnome-keyring0 libgnome-media0 libgnome2-0
  libgnome2-common libgnomecanvas2-0 libgnomecanvas2-common libgnomecups1.0-1
  libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeprintui2.2-0
  libgnomeprintui2.2-common libgnomeui-0 libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgp11-0 libgsf-1-114
  libgsf-1-common libgtksourceview-common libgtksourceview1.0-0 libgtkspell0
  libgtop2-7 libgtop2-common libgvfscommon0 libiec61883-0
  liblaunchpad-integration1 libmetacity0 libnautilus-burn4 libnotify1
  liboil0.3 libpam-gnome-keyring libpanel-applet2-0 libpolkit-gnome0
  libproxy0 librsvg2-2 librsvg2-common libsexy2 libshout3 libsoup-gnome2.4-1
  libsoup2.4-1 libstartup-notification0 libtdb1 libtotem-plparser12 libv4l-0
  libvisual-0.4-0 libvisual-0.4-plugins libwnck-common libwnck22 libxres1
  metacity-common notification-daemon policykit-gnome python-gnome2-desktop
  python-gnome2-extras python-pyorbit
Suggested packages:
  cryptsetup libbonobo2-bin libdv-bin esound libgda3-mysql libgda3-postgres
  libgda3-odbc libgda3-sqlite desktop-base libgnomevfs2-bin librsvg2-bin
  python-gnome2-desktop-doc python-gnome2-extras-doc python-gnome2-extras-dbg
  python-pyorbit-dbg
The following NEW packages will be installed
  easycrypt esound-clients esound-common gamin gnome-icon-theme gnome-keyring
  gnome-media gnome-media-common gnome-mime-data gnome-mount
  gstreamer0.10-alsa gstreamer0.10-plugins-base gstreamer0.10-plugins-good
  gstreamer0.10-x gvfs gvfs-backends libaudiofile0 libavahi-glib1
  libavc1394-0 libbonobo2-0 libbonobo2-common libbonoboui2-0
  libbonoboui2-common libcamel1.2-14 libcanberra-gtk-module libcanberra-gtk0
  libcanberra0 libcdio-cdda0 libcdio-paranoia0 libcdio7 libcroco3 libdv4
  libebook1.2-9 libecal1.2-7 libedataserver1.2-11 libesd-alsa0 libevdocument1
  libevview1 libgail-common libgail18 libgamin0 libgcr0 libgda3-3 libgda3-bin
  libgda3-common libgdl-1-0 libgdl-1-common libgksu2-0 libglade2-0
  libgnome-desktop-2-11 libgnome-keyring0 libgnome-media0 libgnome2-0
  libgnome2-common libgnomecanvas2-0 libgnomecanvas2-common libgnomecups1.0-1
  libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeprintui2.2-0
  libgnomeprintui2.2-common libgnomeui-0 libgnomeui-common libgnomevfs2-0
  libgnomevfs2-common libgnomevfs2-extra libgp11-0 libgsf-1-114
  libgsf-1-common libgtksourceview-common libgtksourceview1.0-0 libgtkspell0
  libgtop2-7 libgtop2-common libgvfscommon0 libiec61883-0
  liblaunchpad-integration1 libmetacity0 libnautilus-burn4 libnotify1
  liboil0.3 libpam-gnome-keyring libpanel-applet2-0 libpolkit-gnome0
  libproxy0 librsvg2-2 librsvg2-common libsexy2 libshout3 libsoup-gnome2.4-1
  libsoup2.4-1 libstartup-notification0 libtdb1 libtotem-plparser12 libv4l-0
  libvisual-0.4-0 libvisual-0.4-plugins libwnck-common libwnck22 libxres1
  metacity-common notification-daemon policykit-gnome python-gnome2-desktop
  python-gnome2-extras python-pyorbit
0 upgraded, 106 newly installed, 0 to remove and 0 not upgraded.
Need to get 16.3MB of archives.
After this operation, 119MB of additional disk space will be used.
Do you want to continue [Y/n]? n
Abort.

Surely, not all of these are needed to run easycrypt...

(I accept that actually it is one of the sub-packages that probably has the unnecessary chain, but as only a technical user/manager lack the knowledge to track that down - happy to be told which one it is so I can go post on their bug tracker instead :) )

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers