Easy Crypt does not support Truecrypt 5

Bug #189747 reported by Steven Harper on 2008-02-06
4
Affects Status Importance Assigned to Milestone
EasyCrypt
High
Unassigned

Bug Description

Truecrypt 5 has now been released

Changes are needed for EasyCrypt to support v5

http://www.truecrypt.org/

EasyCrypt should gracefully support v4.3 and v5.x and possibly (in the info panel) inform the user which they are using.

Related branches

Changed in easycrypt:
status: New → Confirmed
Steven Harper (stevenharperuk) wrote :

Truecrypt no longer provided a command line option / switch to create crypts.

Detailed analysis here

http://ubuntuforums.org/showthread.php?p=4282990

until a way of creating a crypt is made available via API's or through the command line, then I am a bit stuck

Changed in easycrypt:
status: Confirmed → Triaged
Data (ubuntuaddress) wrote :

Hi Steven,

as of yesterday, there is a new version out: Truecrypt 5.1
According to http://www.truecrypt.org/docs/?s=version-history it has command line support for creating new volumes.

I think now it should be possible for Easycrypt to support Truecrypt 5.1, am I wrong?

(Unfortunately, beta freeze for Hardy is quite soon, so I am not sure if a new version would be able to make it into hardy...)

Anyway, great work to far from your side. Keep it on!

Data (ubuntuaddress) wrote :

.. I meant to say: "so far", not "to far"

You are correct, I am going to look into it tonight / this weekend

On Tue, Mar 11, 2008 at 8:44 PM, Data <email address hidden> wrote:
> Hi Steven,
>
> as of yesterday, there is a new version out: Truecrypt 5.1
> According to http://www.truecrypt.org/docs/?s=version-history it has command line support for creating new volumes.
>
> I think now it should be possible for Easycrypt to support Truecrypt
> 5.1, am I wrong?
>
> (Unfortunately, beta freeze for Hardy is quite soon, so I am not sure if
> a new version would be able to make it into hardy...)
>
> Anyway, great work to far from your side. Keep it on!
>
>
>
> --
> Easy Crypt does not support Truecrypt 5
> https://bugs.launchpad.net/bugs/189747
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Steven Harper (stevenharperuk) wrote :

This bug is now fixable with TrueCrypt 5.1 - EasyCrypt 0.2.27 in progress

Changed in easycrypt:
importance: Undecided → High
status: Triaged → Confirmed
Changed in easycrypt:
status: Confirmed → Fix Committed
Data (ubuntuaddress) wrote :

This bug is definitely fixed already, therefore changing the status to Fix Released.
(Just to clean up launchpad a little bit)

Changed in easycrypt:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers