dvdbackup someties lies about which vob file had read errors

Bug #648752 reported by Benjamin Drung on 2010-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dvdbackup
Undecided
Unassigned
dvdbackup (Debian)
Fix Released
Unknown

Bug Description

Report from Kolja Nowak:

When dvdbackup encounters read errors while copying vob files, it prints a message to stderr mentioning the file name of the affected vob. However, this file name is wrong for all except the first vob in a title set.

I noticed this because I copied the same disk using dvdbackup -M and also using cp -r (the dvd is not css encrypted) to compare results, and both told me they had one vob file affected by read errors, but not the same one.

After that, I copied the same disk using a different drive on a different machine, which went through without read errors because this drive is better/newer, and I compared all three results using md5sum. It became evident that the vob file for which dvdbackup told it had read errors was intact, because it was identical in all three cases, and that in reality the vob file for which cp told it had read errors was affected, because all three versions where different.

This happens because dvdbackup.c:DVDCopyTitleVobX reads the source dvd using an abstract api using only title ids and no file names, and therefore needs to reconstruct a file name when printing error messages. It includes the correct title set id in the fake file name, but sets the vob number always to zero, which is only correct for the first vob in a title set.
DVDCopyTitleVobX already has the correct vob number and uses it to construct the the correct target vob file name, and therefore its trivial to use the same number to create a correct file name for the error message.

My attached patch does exactly this.

Benjamin Drung (bdrung) wrote :
Changed in dvdbackup:
milestone: none → 0.4.2
Changed in dvdbackup (Debian):
status: Unknown → Confirmed
Benjamin Drung (bdrung) wrote :

I committed this fix in revision 78.

Changed in dvdbackup:
status: New → Fix Committed
Benjamin Drung (bdrung) on 2012-06-24
Changed in dvdbackup:
status: Fix Committed → Fix Released
Changed in dvdbackup (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.