Search drop-down on Firefox too hard to read

Bug #289042 reported by Aidan Fitzpatrick on 2008-10-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dust theme
Undecided
Unassigned

Bug Description

With the Dust theme installed, Firefox 3's address-bar dropdown works beautifully. However, the search box to the right does not. If you Ctrl + K then start to type a search, when it drops down to complete your search, it does so with a dark background behind black text and is very hard to read.

I'm using the Dust 0.2 .deb and the Firefox 0.1.20080922 theme.

I don't think this is a Firefox theme bug: because Firefox has this problem with or without the theme, and the GTK theme itself shouldn't be enough to make Firefox so hard to use.

Screenshot below shows the (lovely) address-bar dropdown and the hard to read search dropdown.

Kido (greasedbolt) wrote :

Cannot reproduce with latest gtk theme, with or without the firefox theme. This is likely something I've fixed before.

Can you try using the latest gtk theme release (it's at https://code.launchpad.net/dusttheme)?

Aidan Fitzpatrick (afit) wrote :

I've just `bzr branch lp:dusttheme`, copied dusttheme/Dust into ~/.themes after removing the old Dust, and switched to a different theme and back again -- but it hasn't fixed it. I've also tried restarting Firefox.

Any other information I could send over that would help?

Kido (greasedbolt) wrote :

That seems correct. Weird... you seem to be using latest in your screenshot too.

I'm sorry I have to ask a lot but:
Do you have your own .gtkrc file?
Any Firefox extensions you might be using?
Without the Dust Firefox theme, does the address bar have the same colors?

Kido (greasedbolt) on 2008-11-03
Changed in dusttheme:
status: New → Incomplete
Aidan Fitzpatrick (afit) wrote :

* No .gtkrc file
* I've tried removing all extensions apart from the stock Ubuntu one
* Yes, without the Dust Firefox theme, the colours are still broken

I've since upgraded to Ubuntu 8.10 and still have the problem, so I've moved away from Dust for the time being.

Thanks.

David Tombs (dgtombs) wrote :

I have the same issue, also without Dust theme on Firefox. Not that this is the "suggestions" dropdown (activated when you start typing something), not the engine picker.

David Tombs (dgtombs) wrote :

Sorry, should read "Note that this is..."

Aidan Fitzpatrick (afit) wrote :

FYI still have this issue with 0.3.4 and 0.1.20090217 on Jaunty 9.04.

Allan Caeg (allancaeg) wrote :

For dark themes, I always use http://userstyles.org/styles/10822

That should fix it. :)

Aidan Fitzpatrick (afit) wrote :

That'll teach me not to test properly; if I pull up a guest session and apply Dust, Firefox works correctly.

I do not have a .gtkrc but clearly something else is interfering. I'll have to figure out what it is...

Suggest INVALID.

David, as you reported the same issue -- can you replicate it in a guest session?

Kido (greasedbolt) wrote :

Don't be so harsh on yourself. :P Have you tried Firefox in Safe Mode?

 In any case, I'll leave this open until it's marked for expiration or David answers.

David Tombs (dgtombs) wrote :

Indeed a guest session took care of the problem. Light text on dark background.

I then tried FF in safe mode, which also fixed the issue. I will try some more testing and get back to you.

David Tombs (dgtombs) wrote :

I found it! Believe it or not, disabling "Live HTTP Headers" extension fixed it.

I also get "nsHeaderInfo: registerSelf called!" twice on the console when the bad extension is enabled. Could this be related?

Aidan Fitzpatrick (afit) wrote :

Believe it or not indeed. Disabling "Live HTTP Headers" does fix it.

Thanks David.

Bonus points if you can get them to work together.

Kido (greasedbolt) on 2009-04-14
Changed in dusttheme:
status: Incomplete → Invalid
David Tombs (dgtombs) wrote :

For reference, Live HTTP Headers bug: https://www.mozdev.org/bugs/show_bug.cgi?id=20809

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.