repeatedly asks for encryption password when backing up, even though "remember password" is ticked

Bug #989750 reported by Christopher Barrington-Leigh on 2012-04-27
158
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Duplicity
Undecided
Unassigned
deja-dup (Ubuntu)
Undecided
Unassigned

Bug Description

I've set deja-dup to back up automatically, and to encrypt files. But it never gets far: every few seconds, it brings up a "password needed" window somewhere out of sight (behind other windows; but that is another problem/feature), even though I've told it to remember the password.

So using this backup software seems entirely impractical; it will never finish.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: deja-dup 20.1-0ubuntu0.2
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
Uname: Linux 3.0.0-17-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Fri Apr 27 09:50:47 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: deja-dup
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in deja-dup (Ubuntu):
status: New → Confirmed
John Donovan (jd-junkmail) wrote :

Can you provide a ETA - I stuck with an unrecovered account

John Donovan (jd-junkmail) wrote :

Is there a work around of not a fix for this yet?
Thanks in advance.

Darren Shafae (dshafae) wrote :

I have had this problem since 11.04, the only workaround is to change the Folder on the Amazon S3 server. I rename the folder and add a letter to the folder: "MyBackup_a" or "MyBackup_b." There is a drawback, it is a fresh copy, which can take a day or so to complete.

Update:...

deja dup continues to ask me for my password, even though I've checked it to remember my password.

However, I think it is backing up after I give it my password. But it says it's backing up as though it's the first time.

It may be that this happens only after I've moved my computer, ie so that it has been disconnected from the network for a while. Maybe something gets tripped up if it cannot find the backup target space, even if temporarily??

Sumeet (sumeetsk) wrote :

I'm experiencing this bug. Has a solution been found?

Sam Shiell (samopn) wrote :

Can I add to this, I am expericeing this bug as well. It started occuring on 27 October 2013, just after Ubuntu had done a software update.

I'm running Ubuntu 12.4

Elias Aarnio (elias-aarnio) wrote :

I would really love to see this fixed. This is again a good example how really important things are just broken. When a fresh Linux user bumps into things like this, he/she is very likely to go the proprietary way.

A year and a half and no solution. This is sad.

I am willing to help but I am not very advanced technically. Please let me know if I can offer any additional information.

I don't have this problem anymore.
I'm using 13.10 and back up to SSH and to a USB disk.
(In fact, I have recently recovered all my data after a laptop theft, thanks to deja-dup).

So. Is anyone following this bug having the problem on 12.10? 13.04? 13.10?

Elias Aarnio (elias-aarnio) wrote :

I am running 13.10 64 bit-version on Lenovo X201 and the problem still exists. I run my backups to a server. My home ADSL is slow, upload about 0,85 Mbps.

I did get rid of the error when I changed the remote backup directory. This however means several days of uploading while doing the first backup.

Mathias Bynke (mabynke) wrote :

I am experiencing this problem in 14.04 (it started recently, I don't remember exactly when).
Deja dup does indeed remember the password, but it prompts for it with regular, short, intervals with the password pre-entered. I just have to press «continue» every few minutes.

Running the backup from the terminal, I get this output when the password prompt shows up:

** (deja-dup:12936): WARNING **: BackendFile.vala:487: Operasjonen ikke tillatt av motoren
** (deja-dup:12936): WARNING **: BackendFile.vala:487: Operasjonen ikke tillatt av motoren
(deja-dup:12936): Gtk-CRITICAL **: _gtk_widget_captured_event: assertion 'WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

The second time the it asked, the last message even appeared three times.
«Operasjonen ikke tillatt av motoren» means «Operation not permitted by the engine».

Changing the backup destination folder does not fix the problem. In fact, no files show up in the new folder at all.
I am backing up over ftp.

Christian González (droetker) wrote :

Same here. Backing up over samba share. Deja-Dup is completely unuseable, using Ubuntu 14.10 and Arch Linux (Deja-Dup 32.0, duplicity 6.5 and 7.0).

Aizelauna (aize-launa) wrote :

I had the same problem in my PC.
So to try to resolve it, I used this command to activate deja-dup logs :
  export DEJA_DUP_DEBUG=1
  deja-dup --backup

And then I saw in the terminal a permission error on this folder ~/.gnupg.
I changed the owner of this folder from root to my username and now the backup seems to work.

Mathias Bynke (mabynke) wrote :

I already have the ownership of that folder, so that does not seem to be the problem for me. I did, however, try activating deja-dup logs like you did. I have attached the last bit of the output.
«krypterte data» means «encrypted data», and «dekryptering mislyktes: ugyldig pakke» means «decryption failed: invalid package».
The error messages are to vague for me to interpret in a meaningful way.

I have just made a fresh install of Ubuntu, and I really thought that would fix the problem.

Michael Hull (mhull-m) wrote :

I had the same problem. I also had to start a fresh backup to a new location. My storage location was a local disk.

Ubuntu 14.04 seems to have to have the same problem.
 Back-up required repetitive password endless !!!!
I'm a new Ubuntu user, I don't know how to solve dis problem.

Dennis Heinson (dheinson) wrote :

Can this issue be escalated somehow? The backup feature is pretty much useless without it being fixed. The importance still has not been decided upon, and the bug is more than three years old.

Naël (nathanael-naeri) wrote :

There are several other reports of Déjà Dup repeatedly prompting for the encryption passphrase when encountering a GPG error (although not necessarily the same as that in Mathias's log) during an incremental backup, and only successfully completing full backups. See e.g.

# "encrypted message has been manipulated"
https://bugs.launchpad.net/deja-dup/+bug/1540286

# "can't handle text lines longer than 19995 characters"
https://bugs.launchpad.net/ubuntu/+source/deja-dup/+bug/1019293

# "block_filter 0x12345678: read error"
https://bugs.launchpad.net/ubuntu/+source/deja-dup/+bug/883742

People still affected, check logs with 'DEJA_DUP_DEBUG=1 deja-dup --backup' to find out if your problem is triggered by the same GPG error?

Naël (nathanael-naeri) wrote :

For people like Mathias having a GPG error similar to "block_filter, read error, pending bytes":

DUPLICITY: ERROR 31 GPGError
DUPLICITY: . GPGError: GPG Failed, see log below:
DUPLICITY: . ===== Begin GnuPG log =====
DUPLICITY: . gpg: CAST5 encrypted data
DUPLICITY: . gpg: encrypted with 1 passphrase
DUPLICITY: . gpg: block_filter 0xdaebf0: read error (size=12376,a->size=12376)
DUPLICITY: . gpg: [don't know]: invalid packet (ctb=7b)
DUPLICITY: . gpg: [don't know]: invalid packet (ctb=3a)
DUPLICITY: . gpg: mdc_packet with invalid encoding
DUPLICITY: . gpg: decryption failed: invalid packet
DUPLICITY: . gpg: [don't know]: invalid packet (ctb=46)
DUPLICITY: . gpg: block_filter: pending bytes!
DUPLICITY: . ===== End GnuPG log =====

in the log of their 'DEJA_DUP_DEBUG=1 deja-dup --backup', see bug 1159177 and how it was solved for the person who reported it.

LinuxLover (linux-klomp) wrote :

Running Ubuntu 14.04.4 LTS and also have this problem.
Trying to setup a new backup, but cannot get the first full backup completed...

Vej (vej) wrote :

@ Everyone affected: Does this occur even on the first backup done, or only on later backups?

tags: added: trusty
Changed in deja-dup (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for deja-dup (Ubuntu) because there has been no activity for 60 days.]

Changed in deja-dup (Ubuntu):
status: Incomplete → Expired
Joseph Hedgcorth (shruggerman) wrote :

This bug says it's expired but it's affecting me anyways (on 16.04 and on 17.04: I upgraded specifically because I hoped it would fix the bug) so I'm bumping.

@Vej: Yes, this is happening on my first backup. (Well, it says I've backupped 247 days ago which is approximately when I installed Ubuntu, but I don't really think I did.)

This is the error I get:

DUPLICITY: ERROR 31 GPGError
DUPLICITY: . GPGError: GPG Failed, see log below:
DUPLICITY: . ===== Begin GnuPG log =====
DUPLICITY: . gpg: WARNING: "--no-use-agent" is an obsolete option - it has no effect
DUPLICITY: . gpg: AES encrypted data
DUPLICITY: . gpg: encrypted with 1 passphrase
DUPLICITY: . gpg: decryption failed: Bad session key
DUPLICITY: . ===== End GnuPG log =====
DUPLICITY: .

Naël (nathanael-naeri) on 2017-05-19
Changed in deja-dup (Ubuntu):
status: Expired → Confirmed
tags: added: xenial
removed: amd64 oneiric running-unity
Naël (nathanael-naeri) wrote :

Status changed to "Confirmed" because some users are still affected, on recent Ubuntu releases.

We still don't have enough information for triaging though. Everyone affected, please provide the full log when replicating the problem, not just the GPG error:

$ DEJA_DUP_DEBUG=1 deja-dup --backup > deja-dup.log

You may want to scrub the log of any incriminating file names or details. Also, if the log is really too large, limit it to e.g. the last 1000 lines or whatever number of lines is enough to include enough information about the issue:

$ DEJA_DUP_DEBUG=1 deja-dup --backup | tail -n 1000 > deja-dup.log

Also of interest may be your settings (please scrub the file of any incriminating file names or details):

$ gsettings list-recursively org.gnome.DejaDup > deja-dup.gsettings

And I've also found in the past that the content of Déjà-Dup's cache directory could provide valuable insight over the available backup chains:

$ ls -lR .cache/deja-dup/ > deja-dup.cachedir

Thanks.

Changed in deja-dup:
status: New → Confirmed
Naël (nathanael-naeri) wrote :

Added this bug to the Duplicity project, as it looks more like a bug in Duplicity than a bug in Déjà-Dup, judging from the currently available log files.

Also it's worth noticing that the GPG error reported by Joseph Hedgcorth in comment 24 is not the same as the GPG error reported by Mathias Binke in comment 15, so these two reporters may encounter different issues resulting in the same GPG error code (31).

Naël (nathanael-naeri) wrote :

@Joseph: When Vej wrote "the first backup", I think he meant "a full backup" (as opposed to an incremental backup), not the actual first backup of your documents.

You can force a full backup by backing up to a new location, e.g. a different folder on the server/disk that you are backing up to. Don't forget to log Déjà-Dup's output in case the issue occurs.

Beware that a full backup can take some time, depending on how much data you have, so when running tests, you may want to only backup a few files and folders.

Thanks

This has long been fixed, so closing it now.

Please upgrade to the current version of duplicity. This will assure that any bugs fixed since your release are available and my fix your issue.

There are three options:

* Release tarball Install - https://launchpad.net/duplicity/+download
* Daily duplicity builds - https://launchpad.net/~duplicity-team/+archive/ubuntu/daily
* Stable duplicity builds - https://launchpad.net/~duplicity-team/+archive/ubuntu/ppa

Changed in duplicity:
status: New → Fix Released
Naël (nathanael-naeri) wrote :

Awesome, thanks for weighting in Kenneth.

I've set the status to "Invalid" (not a bug) for deja-dup since the bug was in duplicity.

no longer affects: deja-dup
Changed in deja-dup (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers