UnboundLocalError (local variable 'ch_err' referenced before assignment) in ssh_paramiko_backend.py

Bug #1867468 reported by David Tucker
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duplicity
Fix Released
Medium
Unassigned

Bug Description

duplicity 0.8.10fin
Python 3.8.1
from Homebrew on macOS 10.13.6

STDOUT
Attempt 1 failed. UnboundLocalError: local variable 'ch_err' referenced before assignment
Attempt 2 failed. UnboundLocalError: local variable 'ch_err' referenced before assignment
Attempt 3 failed. UnboundLocalError: local variable 'ch_err' referenced before assignment
Attempt 4 failed. UnboundLocalError: local variable 'ch_err' referenced before assignment

STDERR
ssh: Socket exception: Operation timed out (60)
Giving up after 5 attempts. UnboundLocalError: local variable 'ch_err' referenced before assignment

I didn't get a full traceback, but I suspect the issue is here:
https://bazaar.launchpad.net/~duplicity-team/duplicity/0.8-series/view/head:/duplicity/backends/ssh_paramiko_backend.py#L408

Revision history for this message
David Tucker (dmtucker) wrote :

This occurred during a call to `duplicity cleanup scp://` (with GPG opts).

Revision history for this message
Kenneth Loafman (kenneth-loafman) wrote :

Thanks for the bug report! It helps.

Changed in duplicity:
importance: Undecided → Medium
milestone: none → 0.8.12
status: New → Fix Committed
Changed in duplicity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers