Duplicity crashing, unicode issue

Bug #1859036 reported by Stefan on 2020-01-09

This bug report will be marked for expiration in 57 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duplicity
High
Unassigned

Bug Description

Doing backups onto b2 keeps giving me errors:

test.sh -->PASSPHRASE="test" duplicity --encrypt-key example /mnt/ntfs/newsharecopy/ b2://example:example@example

root@datastore:/home/administrator/Desktop# ./test.sh
Synchronizing remote metadata to local cache...
Copying duplicity-full-signatures.20190927T125429Z.sigtar.gpg to local cache.
Attempt 1 failed. TypeError: argument can't be <type 'unicode'>
Attempt 2 failed. TypeError: argument can't be <type 'unicode'>
Attempt 3 failed. TypeError: argument can't be <type 'unicode'>
Attempt 4 failed. TypeError: argument can't be <type 'unicode'>
^C

version is 8.09

Stefan (stefan-cp) wrote :

Tryed to change #!/usr/bin/env python2.7 to #!/usr/bin/env python3
 but I get
Traceback (most recent call last):
  File "/usr/local/bin/duplicity", line 55, in <module>
    from duplicity.dup_main import main
ModuleNotFoundError: No module named 'duplicity'

Changed in duplicity:
status: New → In Progress
assignee: nobody → Kenneth Loafman (kenneth-loafman)
importance: Undecided → High
milestone: none → 0.8.10

How did you install duplicity? 0.8.09 is running shebangs with python3 not python2.7.

Changed in duplicity:
status: In Progress → Won't Fix
status: Won't Fix → Incomplete
Stefan (stefan-cp) wrote :

I tried multiple ways.
Before it was installed with apt and it was uploading fine until this error occurred.
I tried reinstalling it with apt, I tried snap, pip and pip3.
In the end I installed with pip and changed env in config file to python 2.7 to fix the no module duplicity error that I kept getting after reinstalling, but even so I couldn't continue the uploads.
Now I have started upload into the fresh b2 bucket.
If you wish to see any config files I will provide them, just let me know which,.

Changed in duplicity:
status: Incomplete → In Progress

At this point you probably have multiple copies of duplicity installed with differing versions.

Do the commands and you should see:

$ find /usr -type f -name 'duplicity'
/usr/bin/duplicity

$ find /usr -type d -name 'duplicity*'
/usr/lib/python3/dist-packages/duplicity-0.8.09.egg-info
/usr/lib/python3/dist-packages/duplicity
/usr/share/doc/duplicity

If you see more than this, remove all of them manually, rerun to check, then reinstall using something other than pip.

There are four options:

* Release tarball install - https://launchpad.net/duplicity/+download
* Daily duplicity builds - https://launchpad.net/~duplicity-team/+archive/ubuntu/daily-dev-trunk
* Stable snap builds - “sudo snap install duplicity —classic"
* Latest snap builds - “sudo snap install duplicity —classic —edge"

Changed in duplicity:
status: In Progress → Incomplete
Changed in duplicity:
milestone: 0.8.10 → none
assignee: Kenneth Loafman (kenneth-loafman) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers