missing targets in multitarget may only be skipped if they can be recreated

Bug #1858207 reported by Jose Riha on 2020-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned

Bug Description

Testcase:

$ cat /tmp/multi.json
 [
  {
   "url": "file:///tmp/fragile"
  },
  {
   "url": "file:///tmp/solid"
  }
 ]

$ duplicity --no-encryption /etc/ 'multi:///tmp/multi.json?mode=mirror'
.. backup finishes, /tmp/fragile and /tmp/solid contains the same data

# corrupt the first target

$ cat /tmp/multi.json
 [
  {
   "url": "file:///xtmp/fragile"
  },
  {
   "url": "file:///tmp/solid"
  }
 ]

$ duplicity list-current-files multi:///tmp/multi.json
Giving up after 1 attempts. OSError: [Errno 2] No such file or directory: '/xtmp/fragile

# corrupt the first target so that it can still be written to

$ cat /tmp/multi.json
 [
  {
   "url": "file:///tmp/fragile.new"
  },
  {
   "url": "file:///tmp/solid"
  }
 ]

$ duplicity list-current-files multi:///tmp/multi.json
works..

# /tmp/fragile.new is created (as empty)

Expectation:

list works even if /xtmp/fragile may not be created.

System info:

Arch Linux
duplicity 0.7.19-2
python2 2.7.17-1

Please upgrade to the current version of duplicity. This will assure that any bugs fixed since your release are available and may fix your issue.

There are three options:

* Release tarball Install - https://launchpad.net/duplicity/+download
* Daily duplicity builds - https://launchpad.net/~duplicity-team/+archive/ubuntu/daily-dev-trunk
* Stable snap builds - “sudo snap install duplicity —classic"
* Latest snap builds - “sudo snap install duplicity —classic —edge"

NOTE: UNinstall duplicity first if it was installed via the distribution repository. For Ubuntu, that would be "sudo apt-get purge duplicity".

Changed in duplicity:
status: New → In Progress
importance: Undecided → Medium
milestone: none → 0.8.10
Jose Riha (jose1711) wrote :

reproduced with duplicity 0.8.08

Changed in duplicity:
assignee: nobody → Kenneth Loafman (kenneth-loafman)
Changed in duplicity:
assignee: Kenneth Loafman (kenneth-loafman) → nobody
status: In Progress → Fix Committed
Changed in duplicity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers