0.8 series : can't get duplicity to run : UnicodeDecodeError

Bug #1810573 reported by Sébastien Stoquert on 2019-01-05
This bug report is a duplicate of:  Bug #1851668: unicode problem in tempdir.py. Edit Remove
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Duplicity
Undecided
Unassigned

Bug Description

Hello,

I'm running Ubuntu 18.04.1 LTS and duplicity from the repository from today (05/01/19) and the following error occurs when running any command with duplicity.
I followed the instructions of https://docs.ovh.com/gb/en/storage/pca/duplicity/, in order to enable pca backend on my ubuntu machine.

I tried to purge and re-install python, duplicity and all requirements without success.
The duplicity 0.7.17 works fine on my computer (tried with sftp).

Thank you for your time and answers

root@NAS-SEB:/home/sebastien/duplicity# PYTHONPATH=/home/sebastien/duplicity bin/duplicity -V
Traceback (innermost last):
  File "bin/duplicity", line 1678, in <module>
    with_tempdir(main)
  File "bin/duplicity", line 1664, in with_tempdir
    fn()
  File "bin/duplicity", line 1497, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/home/sebastien/duplicity/duplicity/commandline.py", line 1138, in ProcessCommandLine
    args = parse_cmdline_options(cmdline_list)
  File "/home/sebastien/duplicity/duplicity/commandline.py", line 279, in parse_cmdline_options
    parser = OPHelpFix(option_class=DupOption, usage=usage())
  File "/home/sebastien/duplicity/duplicity/commandline.py", line 944, in usage
    msg = msg + _(u"Backends and their URL formats:") + u"""
 UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 28: ordinal not in range(128)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers