Shebang should point to Python 2

Bug #1788150 reported by Kenneth Loafman on 2018-08-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duplicity
Undecided
Unassigned
duplicity (Ubuntu)
Low
Unassigned

Bug Description

I think we should change the shebang line to ensure Python 2 usage, as I have 3 set as default. This will produce and error as the statvfs package is deprecated, but available, in 2 and removed in 3. The error this produces in Deja Dup is "could not understgand duplicity version".

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in duplicity (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

Looking a bit the issue seems fixed in 18.10

Changed in duplicity (Ubuntu):
status: Incomplete → Fix Released
Sebastien Bacher (seb128) wrote :

Unsure how to reproduce the issue there, "python" default to 2.7 on bionic when that one is installed (which is the case when using duplicate since it's a depends). Did you manually change your default python version and if so how did you do it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions