Porting to Python 3 for compatibility reasons with Ubuntu 18.04

Bug #1732183 reported by Or Schiro on 2017-11-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Duplicity
Undecided
Unassigned

Bug Description

Dear all,

I am wondering if there are plans to port over Duplicity to Python 3 to make it compatible with Ubuntu 18.04 and ship it by default. See this related discussion [1].

Thank you! :-)

Robert

[1] https://bugs.launchpad.net/ubuntu/+source/deja-dup/+bug/1731941/comments/1

Or Schiro (orschiro) on 2017-11-14
summary: - Porting to Python3 for compatibility reasons with Ubuntu 18.04
+ Porting to Python 3 for compatibility reasons with Ubuntu 18.04

Probably not given that the release has to ready in just a few months. Lots of moving parts, but it would help with the Unicode nonsense.

Or Schiro (orschiro) wrote :

Thanks, Kenneth!

Appreciate your reply. Good to know where we are standing right now.

Changed in duplicity:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers