BackendException with oauth2client 4.0.0

Bug #1638236 reported by Christian Mund on 2016-11-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Kenneth Loafman

Bug Description

Duplicity doesn't seem to be compatible with the recently released oauth2client 4.0.0. Downgrading to oauth2client 3.0.0 reverts back to a working state.

Duplicity version: community/duplicity 0.7.09-1
Python version: 2.7.12
OS Distro and version: Arch Linux current as of 2016/11/01 10:00 UTC
Type of target filesystem: Linux x86_64
Log output from -v9 option:

Using archive dir: /root/.cache/duplicity/<HASH>
Using backup name: <HASH>
Import of duplicity.backends.acdclibackend Succeeded
Import of duplicity.backends.azurebackend Succeeded
Import of duplicity.backends.b2backend Succeeded
Import of duplicity.backends.botobackend Succeeded
Import of duplicity.backends.cfbackend Succeeded
Import of duplicity.backends.copycombackend Succeeded
Import of duplicity.backends.dpbxbackend Failed: No module named dropbox
Import of duplicity.backends.gdocsbackend Succeeded
Import of duplicity.backends.giobackend Succeeded
Import of duplicity.backends.hsibackend Succeeded
Import of duplicity.backends.hubicbackend Succeeded
Import of duplicity.backends.imapbackend Succeeded
Import of duplicity.backends.lftpbackend Succeeded
Import of duplicity.backends.localbackend Succeeded
Import of duplicity.backends.mediafirebackend Succeeded
Import of duplicity.backends.megabackend Succeeded
Import of duplicity.backends.multibackend Succeeded
Import of duplicity.backends.ncftpbackend Succeeded
Import of duplicity.backends.onedrivebackend Succeeded
Import of duplicity.backends.par2backend Succeeded
Import of duplicity.backends.pydrivebackend Succeeded
Import of duplicity.backends.rsyncbackend Succeeded
Import of duplicity.backends.ssh_paramiko_backend Succeeded
Import of duplicity.backends.ssh_pexpect_backend Succeeded
Import of duplicity.backends.swiftbackend Succeeded
Import of duplicity.backends.sxbackend Succeeded
Import of duplicity.backends.tahoebackend Succeeded
Import of duplicity.backends.webdavbackend Succeeded
MultiBackend: use store gdocs://<email address hidden>/folder
MultiBackend: set env GOOGLE_DRIVE_SETTINGS = /etc/duplicity/pydrive-username.conf
Using temporary directory /tmp/duplicity-v7qhui-tempdir
Backend error detail: Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1546, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1540, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1375, in main
    action = commandline.ProcessCommandLine(sys.argv[1:])
  File "/usr/lib/python2.7/site-packages/duplicity/commandline.py", line 1109, in ProcessCommandLine
    globals.backend = backend.get_backend(args[0])
  File "/usr/lib/python2.7/site-packages/duplicity/backend.py", line 223, in get_backend
    obj = get_backend_object(url_string)
  File "/usr/lib/python2.7/site-packages/duplicity/backend.py", line 209, in get_backend_object
    return factory(pu)
  File "/usr/lib/python2.7/site-packages/duplicity/backends/multibackend.py", line 185, in __init__
    store = duplicity.backend.get_backend(url)
  File "/usr/lib/python2.7/site-packages/duplicity/backend.py", line 223, in get_backend
    obj = get_backend_object(url_string)
  File "/usr/lib/python2.7/site-packages/duplicity/backend.py", line 209, in get_backend_object
    return factory(pu)
  File "/usr/lib/python2.7/site-packages/duplicity/backends/pydrivebackend.py", line 40, in __init__
    raise BackendException('PyDrive backend requires PyDrive installation'
BackendException: PyDrive backend requires PyDrive installationPlease read the manpage to fix.

Related branches

Christian Mund (kkkrist) on 2016-11-06
description: updated
Changed in duplicity:
assignee: nobody → Kenneth Loafman (kenneth-loafman)
importance: Undecided → Medium
milestone: none → 0.7.16
status: New → In Progress
Changed in duplicity:
milestone: 0.7.16 → 0.7.17
Christian Mund (kkkrist) wrote :

Is this still a problem?

According to my package manager logs I've been on oauth2client 4.0.0 since 2017/02/24 and haven't reverted to 3.0.0 ever since (so it must have worked since then). At that time duplicity 0.7.11 and google-api-python-client 1.6.2 was used.

Currently it still runs just fine (using duplicity 0.7.15, google-api-python-client 1.6.4 and oauth2client 4.1.2).

-Christian

Changed in duplicity:
milestone: 0.7.17 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers