failing test on OpenBSD because tar/gtar not found (patch provided)

Bug #1623342 reported by Daniel Jakots on 2016-09-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned

Bug Description

Hi,

On OpenbSD I had a failing test because it didn't found gtar:
- Exception: Platform OpenBSD-6.0-amd64-64bit not supported by tar/gtar.

It's done on 0.7.10, tests were not enabled before so I can't be sure, but I don't think it's new. A diff that was cooked so it works on OpenBSD but also on other BSD too: http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/sysutils/duplicity/patches/patch-testing_functional_test_restart_py?rev=1.1&content-type=text/x-cvsweb-markup

Sorry if it's not the best way to submit a patch, I'm not really used with duplicity development :)

Please paste the patch to the bug report and mark it as a patch. Thanks.

On Wed, Sep 14, 2016 at 1:39 AM, Daniel Jakots <email address hidden> wrote:

> Public bug reported:
>
> Hi,
>
> On OpenbSD I had a failing test because it didn't found gtar:
> - Exception: Platform OpenBSD-6.0-amd64-64bit not supported by tar/gtar.
>
> It's done on 0.7.10, tests were not enabled before so I can't be sure,
> but I don't think it's new. A diff that was cooked so it works on
> OpenBSD but also on other BSD too: http://cvsweb.openbsd.org/cgi-
> bin/cvsweb/ports/sysutils/duplicity/patches/patch-
> testing_functional_test_restart_py?rev=1.1&content-type=text/x-cvsweb-
> markup
>
> Sorry if it's not the best way to submit a patch, I'm not really used
> with duplicity development :)
>
> ** Affects: duplicity
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are subscribed to
> Duplicity.
> https://bugs.launchpad.net/bugs/1623342
>
> Title:
> failing test on OpenBSD because tar/gtar not found (patch provided)
>
> Status in Duplicity:
> New
>
> Bug description:
> Hi,
>
> On OpenbSD I had a failing test because it didn't found gtar:
> - Exception: Platform OpenBSD-6.0-amd64-64bit not supported by tar/gtar.
>
> It's done on 0.7.10, tests were not enabled before so I can't be sure,
> but I don't think it's new. A diff that was cooked so it works on
> OpenBSD but also on other BSD too: http://cvsweb.openbsd.org/cgi-
> bin/cvsweb/ports/sysutils/duplicity/patches/patch-
> testing_functional_test_restart_py?rev=1.1&content-type=text/x-cvsweb-
> markup
>
> Sorry if it's not the best way to submit a patch, I'm not really used
> with duplicity development :)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/duplicity/+bug/1623342/+subscriptions
>

Daniel Jakots (vigdis) wrote :

It's attached and marked as "this attachment contains a solution (patch) for this bug"

Changed in duplicity:
milestone: none → 0.7.11
status: New → Fix Committed
Daniel Jakots (vigdis) wrote :

Thanks!

Changed in duplicity:
importance: Undecided → Medium
Changed in duplicity:
status: Fix Committed → Fix Released
Daniel Jakots (vigdis) wrote :

Hi,

The line which in my patch was
elif platform.system().endswith('BSD'):
became in 0.7.11
elif platform.platform().endswith('BSD'):

The problem is it doesn't match anymore the .endswith('BSD') as

>>> import platform
>>> platform.platform()
'OpenBSD-6.0-amd64-64bit'
>>> platform.system()
'OpenBSD'

Looks like a regression to me. Will reopen and try again.

Changed in duplicity:
status: Fix Released → In Progress
assignee: nobody → Kenneth Loafman (kenneth-loafman)
milestone: 0.7.11 → 0.7.12
Changed in duplicity:
status: In Progress → Fix Committed
Changed in duplicity:
assignee: Kenneth Loafman (kenneth-loafman) → nobody
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers