incorrect response BackendException while downloading signatures file

Bug #1434702 reported by Robin Nehls on 2015-03-20
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

I get a BackendException like this while downloading the signature file when trying to do an incremental backup over ssh.

BackendException: scp get duplicity-full-signatures.20150320T170744Z.sigtar.gpg failed: incorrect response 'C0600 534440306 duplicity-full-signatures.20150320T170744Z.sigtar.gpg'

The problem seems to be in duplicity/backends/ssh_paramiko_backend.py in line 302 and was introduced in rev 1070. Looks like a slip while fixing pep8. The second condition should be a check for equality not a check for identity.

So
if (m is None or m.group(3) != remote_filename):
instead of
if (m is None or m.group(3) is not remote_filename):

I'm using duplicity 0.7.02 and Python 2.7.9 on Arch Linux x64.

I hope this helps

So long

Robin Nehls (man0lis) on 2015-03-21
description: updated
Changed in duplicity:
importance: Undecided → Medium
milestone: none → 0.7.03
status: New → Fix Committed
Leandro Facchinetti (leafac) wrote :

I was facing this bug and the proposed solution worked for me. I had to manually edit the source code, though. So I please ask to release a version with this fix :)

Thanks a lot for all the hard work, Duplicity rocks!

It'll be out in a couple of weeks.

On Wed, Apr 1, 2015 at 5:04 PM, Leandro Facchinetti <email address hidden>
wrote:

> I was facing this bug and the proposed solution worked for me. I had to
> manually edit the source code, though. So I please ask to release a
> version with this fix :)
>
> Thanks a lot for all the hard work, Duplicity rocks!
>
> --
> You received this bug notification because you are subscribed to
> Duplicity.
> https://bugs.launchpad.net/bugs/1434702
>
> Title:
> incorrect response BackendException while downloading signatures file
>
> Status in Duplicity - Bandwidth Efficient Encrypted Backup:
> Fix Committed
>
> Bug description:
> I get a BackendException like this while downloading the signature
> file when trying to do an incremental backup over ssh.
>
> BackendException: scp get duplicity-full-
> signatures.20150320T170744Z.sigtar.gpg failed: incorrect response
> 'C0600 534440306 duplicity-full-
> signatures.20150320T170744Z.sigtar.gpg'
>
> The problem seems to be in duplicity/backends/ssh_paramiko_backend.py
> in line 302 and was introduced in rev 1070. Looks like a slip while
> fixing pep8. The second condition should be a check for equality not a
> check for identity.
>
> So
> if (m is None or m.group(3) != remote_filename):
> instead of
> if (m is None or m.group(3) is not remote_filename):
>
> I'm using duplicity 0.7.02 and Python 2.7.9 on Arch Linux x64.
>
> I hope this helps
>
> So long
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/duplicity/+bug/1434702/+subscriptions
>

Changed in duplicity:
status: Fix Committed → Fix Released

This is still present on ubuntu 15.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

Running ubuntu 16.04 and the problem is still not fixed. manual fix worked fine

This was fixed in version 0.7.03 in the trunk on 05/11/2015. We are up to 07.07.1 as of 04/19/2016. You might want to upgrade.

i installed using the ubuntu repository just this morning.

sudo apt-get install python-paramiko

Go to https://launchpad.net/~duplicity-team/+archive/ubuntu/ppa to and add the repository to your system. Upgrade from there to get the latest stable release. Go to https://launchpad.net/~duplicity-team/+archive/ubuntu/daily for daily builds.

The Ubuntu repos are ancient at the best of times. Sorry about that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers