in WebDAV backend: VerifiedHTTPSConnection instance has no attribute 'tunnel_host'

Bug #1396106 reported by Tim Ruffing on 2014-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned

Bug Description

The WebDAV backend fails with "AttributeError: VerifiedHTTPSConnection instance has no attribute 'tunnel_host'"
Indeed, this is wrong. The attribute is "_tunnel_host", not "tunnel_host", see
https://hg.python.org/cpython/file/2.7/Lib/httplib.py#l686

The problem is here:
https://bazaar.launchpad.net/~duplicity-team/duplicity/0.7-series/view/head:/duplicity/backends/webdavbackend.py#L86

Changing it to _tunnel_host works for me.

duplicity 0.7.0
Python 2.7.8
Arch Linux

Changed in duplicity:
milestone: none → 0.7.01
importance: Undecided → Medium
status: New → Fix Committed
Changed in duplicity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers