Modernize gdocs backend

Bug #1315684 reported by Michael Terry on 2014-05-03
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned

Bug Description

The gdocs backend has a few problems:

1) It uses old branding (Google Docs became Google Drive). This means users may not recognize the term and may not realize duplicity even supports Google Drive.

2) It does not support accounts that have two factor authentication enabled.

3) It uses a deprecated API that Google makes no guarantees for past April 2015. We'd be wise to have something in place before that date. (See https://developers.google.com/google-apps/documents-list/terms)

I propose renaming the backend and url scheme (keeping support for old gdocs: scheme for compatibility) and updating the API to use the official Python API: http://google.github.io/google-api-python-client/

I've got a working port in progress, just working on the authentication, which is notably trickier (seems like we need one of us to have a Developer account for the backend and use secret keys... I'm looking into options).

Fjodor (sune-molgaard) wrote :

Not sure, but https://bugs.launchpad.net/duplicity/+bug/1306242 might be relevant for you.

Michael Terry (mterry) on 2015-02-10
Changed in duplicity:
assignee: Michael Terry (mterry) → nobody
status: In Progress → Confirmed
Changed in duplicity:
status: Confirmed → Fix Committed
importance: Undecided → Medium
milestone: none → 0.7.02
Changed in duplicity:
status: Fix Committed → Fix Released
Alex (astovbou) wrote :

What was gdocs renamed to? Any usage tips and examples would be great.

John (wkmsbu) wrote :

I've updated to 0.7.02-2 (debian testing), but still get the same error. (From the little I can infer from the Traceback, it looks like the gdocs has been set to use gdata…) Does anyone know what's causing this?

Traceback output: http://pastebin.com/bVXNgtT9

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers