Empty file name removal

Bug #1104069 reported by jno on 2013-01-24
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned
duplicity (Ubuntu)
Undecided
Unassigned

Bug Description

So, it's duplicity 0.6.18
in Python 2.7.3
under 3.2.0-29-generic x86_64
from Ubuntu 12.04 LTS server
on amd64-based hp n36l microserver
talking to olbiz.net
served by Pure-FTPd using TLS
backed by GlusterFS.

The duplicity is being ran via duply version 1.5.5.4
Using installed duplicity version 0.6.18, python 2.7.3, gpg 1.4.11, awk 'GNU Awk 3.1.8', bash '4.2.24(1)-release (x86_64-pc-linux-gnu)'.

One may see this "error" (actually, annoying misfeature):

Running 'lftp -c 'source /tmp/duplicity-CmoCxx-tempdir/mkstemp-4Typ9m-1;cd 'backup3/blackbox/';rm '' failed with code 1 (attempt #2)
Error is:
Usage: rm [-r] [-f] files...

in my case it's in /usr/share/pyshared/duplicity/backends/ftpsbackend.py @ delete() method def

I'd propose to guard the last 3 lines (remote_dir = ...; command_line = ...; self.popen_persist(commandline)) with something like

if filelist.rstrip() : # don't even try to remove empty names

I.e. just do nothing if no filenames were given to remove.

jno (jnoster) wrote :

I propose a fix.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Eugene Crosser (crosser) wrote :

I think there are two problems, the one described in the bug #1010381 is that duplicity tries to handle "wrong" files (leftovers from failed ftp transfter) in the local cache. Second is that it in the process of doing that, it tries to remove something on the remote side without specifying the name for that something, resulting in an error. Fixing any or both of these problems will do.

The attachment "ad hoc solution" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
affects: ubuntu → duplicity (Ubuntu)
Changed in duplicity:
importance: Undecided → Medium
milestone: none → 0.6.22
status: New → Fix Committed
Changed in duplicity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers