remove-all-but-n-full broken

Bug #1031269 reported by esskov on 2012-07-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Duplicity
Medium
Unassigned

Bug Description

The remove-all-but-n-full action no longer works correctly with duplicity 0.6.19. It has worked fine with some earlier 0.6.1? version using the same backup script, so this might be a regression.

What seems to happen is that duplicity correctly detects the backup sets to be deleted, then deletes their manifest file(s), but then apparently it concludes that these sets are incomplete and consequently it does not delete the actual volumes.

Last full backup date: Mon Jul 30 21:29:08 2012
Deleting backup sets at times:
Fri Jul 1 01:05:28 2011
Mon Sep 12 23:51:23 2011
Deleting set inc Mon Sep 12 23:51:23 2011
Deleting set full Fri Jul 1 01:05:28 2011
Warning, found incomplete backup sets, probably left from aborted session

duplicity 0.6.19 on Ubuntu 11.10, Python 2.7.2.
Target filesystem: ext4/Linux via scp://.

Related branches

Michael Terry (mterry) wrote :

0.6.18 seems to work fine. 0.6.19 leaves the sigtar files. I'm not seeing the esskov's described behavior of leaving actual volumes, just the sigtar files. But maybe esskov got confused?

Changed in duplicity:
status: New → Confirmed
Michael Terry (mterry) wrote :

The volumes being left is probably bug 1031277, which is specific to SSH.

But I still get the sigtars being left even on a local folder.

Michael Terry (mterry) wrote :

Ah, whoops. My report of it working in 0.6.18 are mistaken. It works in the Debian packaging, because they have applied a patch (which actually tries to deal with the accumulation of files in ~/.cache, which the Debian maintainer does not like).

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/quantal/duplicity/quantal/view/head:/debian/patches/03forcecleanup.dpatch

So this is not a bug in Debian/Ubuntu, but only for upstream or PPA versions. We probably want something more targetted than the above patch though.

Changed in duplicity:
milestone: none → 0.6.20
status: Confirmed → Fix Committed
Changed in duplicity:
importance: Undecided → Medium
Changed in duplicity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers