Duo

The turn line in Tk interface is reset between games

Bug #298548 reported by David Soulayrol on 2008-11-15
2
Affects Status Importance Assigned to Milestone
Duo
Low
David Soulayrol

Bug Description

When a game ends, the player is asked is he wants to continue. If another game must start, the winner will begin.

Nevertheless, the turn line is refreshed to the position of the human player (south) while the new cards are dealt, which disturbs the player.

Changed in duo:
importance: Undecided → Low
status: New → Confirmed
Changed in duo:
assignee: nobody → dsoulayrol
David Soulayrol (dsoulayrol) wrote :

Additionally the turn line is badly drawn on the south position on some systems. This bad behaviour was observed on Leopard and on Debian w/ awesome as window manager. (I guess it has something with the respect of windows hints, or something like that)

David Soulayrol (dsoulayrol) wrote :

The turn line is now only displayed when a Turn message was received.
The bad drawing was caused by width and height dimensions reversal in some lines.

Changed in duo:
status: Confirmed → Fix Committed
Changed in duo:
milestone: none → 0.9

Released in 0.9

Changed in duo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers