Duo

Moving from one language to another does not reset not-translated sentences

Bug #298527 reported by Guillaume Lemaître on 2008-11-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Duo
Low
Guillaume Lemaître

Bug Description

Suppose that LANG="fr_FR.UTF-8", so the game is in french.

If you go through the language selection menu and select German for example, all the sentences that are translated in fr.po but not in de.po stay in French.

I think it would be better if not-translated sentences would go back to default language, in order to be consistent with observed behaviour when LANG="de_DE.UTF-8"

Changed in duo:
importance: Undecided → Low
status: New → Confirmed

Maybe some other sentences to translate are linked to exception catching that are directly diisplayed on the console.

For example, the error when a package cannot be imported is currently english only.

P.S.: I still cannot update Rosetta site with latest .pot and .po

Changed in duo:
assignee: nobody → guillaume-lemaitre

In fact, the issue is not quite like this: some strings for which translation does not exist get back to default, whereas some others not.

For example, "Ready", "Pass" buttons and "About" information window never change of localization.

I'm not python-aware enough at this time being to find why such a thing occurs: not all the application seems to belong to the same domain. Maybe later?

Changed in duo:
assignee: guillaume-lemaitre → nobody

It seems that the solution may lay in using tkInter.StringVar elements for the pass and ready buttons, but I still haven't find out how. Furthermore, why those two buttons would be refreshed on a different basis than the remaining widgets of the window?

Fixed in rev. 22

Changed in duo:
assignee: nobody → guillaume-lemaitre
status: Confirmed → Fix Committed
Changed in duo:
milestone: none → 0.9

Released in 0.9

Changed in duo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers