Duo

Bad management of PASS card at start

Bug #296253 reported by Guillaume Lemaître on 2008-11-10
2
Affects Status Importance Assigned to Milestone
Duo
High
David Soulayrol

Bug Description

If first card is a PASS one, I was the first to play. I had the ability to play, and then hand goes to the player after the next one. Normally, I shouldn't have been able to play, and the next player shall have start.

Changed in duo:
status: New → Confirmed
Changed in duo:
assignee: nobody → dsoulayrol
importance: Undecided → High
Changed in duo:
status: Confirmed → Fix Committed
David Soulayrol (dsoulayrol) wrote :

The fix commited introduces a new little problem : after the first game is finished: the first player is now the next player after the player who won. Additionally, the rotation of the game is not reinitialized to clockwise. I have to check what are the exact rules before fixing that.

Changed in duo:
status: Fix Committed → In Progress

Maybe this should be tracked down in bug #298548?

David Soulayrol (dsoulayrol) wrote :

I agree both #298548 and my last comment are close to each other. But this last problem is a raw game engine problem (due to a sketchy fix of mine) in the line of this present bug, whereas #298548 is a pure Tk related GUI problem.

David Soulayrol (dsoulayrol) wrote :

The dealer is now clearly identified by the game. For now, the human player is always the first dealer. The first player to move is the first on the left of the dealer. For the next game, the new dealer is the first on the left of the previous dealer.

When retrurning the first card on the heap, special cards are nearly applied as in the UNO rules:
- On reverse, the first player is the one on the right of the dealer, and the game continue counter-clockwise.
- On pass, the first player is the second on the left of the dealer.
- On wild cards, a new card is drawn by the dealer, because the game protocol does not know how to handle this yet.

Changed in duo:
status: In Progress → Fix Committed
Changed in duo:
milestone: none → 0.9

Released in 0.9

Changed in duo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers