drizzleslap guid test fails

Bug #568095 reported by Lee Bieber on 2010-04-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
High
Eric Day
Cherry
High
Eric Day

Bug Description

As of build 1475, the guid test has failed 5 of 7 times

See the complete log at http://hudson.drizzle.org/view/Drizzle-staging/job/drizzle-staging-drizzleslap/193/

Wed Apr 21 12:36:19 2010 INFO: Running test: guid with /home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap --port=9306 --label=guid --concurrency=50 --iterations=10 --csv=/tmp/drizzleslap-1502.csv --number-int-cols=2 --number-char-cols=3 --auto-generate-sql --auto-generate-sql-guid-primary --auto-generate-sql-load-type=write --number-of-queries=100000 --engine=innodb
Wed Apr 21 12:39:55 2010 INFO: guid Failed with 256
/home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap: Cannot run query INSERT INTO t1 VALUES (uuid(),601509202,1905068689,'5dfQWSPWlOQP0HHO5AMpvHa22L9mBXR806QNRrtC7BT7KmYQxm7k3hmxvojyBB649YRcFChFOAMkxu2mZ9Wcj9Qex9c8KaCWyXy5kfK0ijcfTXH2gfXFoxtlyLmBvq','ZtMXzy3Jql2QGOxZQW4plteXWds8oozLZDkOBfktOeJY29xLf22GvhnHAYQyCPBlWnAhRmQjGlGJm5YH7aQu7DCHdW7pvARPyTyHFOsX10ig66x5hF0oT4yya5oLG7','e6cSFjk76d8pHEn7BSMB9j77iZ4MuKLOIxsZYcheEhJXn7WyRt2SS9bAbYOTklm3aeS6F1dLiokLvFKF0MjSNBXyjnKJZ6M7kr6rkj4RNpoBw0QwM1Ge4fcfRwzsuL') ERROR : Duplicate entry 'a959aff6-4d7d-11df-8dbf-000e0c434fcf' for key 'PRIMARY'

Related branches

Lee Bieber (kalebral) on 2010-04-21
Changed in drizzle:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Brian Aker (brianaker)
milestone: none → 2010-04-26
Download full text (3.5 KiB)

Hi!

Can we see if build 1471 can pass? And if it does check build 1472?

Thanks,
 -Brian

On Apr 21, 2010, at 2:33 PM, Lee Bieber wrote:

> Public bug reported:
>
> As of build 1475, the guid test has failed 5 of 7 times
>
> See the complete log at http://hudson.drizzle.org/view/Drizzle-
> staging/job/drizzle-staging-drizzleslap/193/
>
> Wed Apr 21 12:36:19 2010 INFO: Running test: guid with /home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap --port=9306 --label=guid --concurrency=50 --iterations=10 --csv=/tmp/drizzleslap-1502.csv --number-int-cols=2 --number-char-cols=3 --auto-generate-sql --auto-generate-sql-guid-primary --auto-generate-sql-load-type=write --number-of-queries=100000 --engine=innodb
> Wed Apr 21 12:39:55 2010 INFO: guid Failed with 256
> /home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap: Cannot run query INSERT INTO t1 VALUES (uuid(),601509202,1905068689,'5dfQWSPWlOQP0HHO5AMpvHa22L9mBXR806QNRrtC7BT7KmYQxm7k3hmxvojyBB649YRcFChFOAMkxu2mZ9Wcj9Qex9c8KaCWyXy5kfK0ijcfTXH2gfXFoxtlyLmBvq','ZtMXzy3Jql2QGOxZQW4plteXWds8oozLZDkOBfktOeJY29xLf22GvhnHAYQyCPBlWnAhRmQjGlGJm5YH7aQu7DCHdW7pvARPyTyHFOsX10ig66x5hF0oT4yya5oLG7','e6cSFjk76d8pHEn7BSMB9j77iZ4MuKLOIxsZYcheEhJXn7WyRt2SS9bAbYOTklm3aeS6F1dLiokLvFKF0MjSNBXyjnKJZ6M7kr6rkj4RNpoBw0QwM1Ge4fcfRwzsuL') ERROR : Duplicate entry 'a959aff6-4d7d-11df-8dbf-000e0c434fcf' for key 'PRIMARY'
>
> ** Affects: drizzle
> Importance: High
> Assignee: Brian Aker (brianaker)
> Status: Confirmed
>
> ** Affects: drizzle/cherry
> Importance: High
> Assignee: Brian Aker (brianaker)
> Status: Confirmed
>
> ** Changed in: drizzle
> Importance: Undecided => High
>
> ** Changed in: drizzle
> Status: New => Confirmed
>
> ** Changed in: drizzle
> Assignee: (unassigned) => Brian Aker (brianaker)
>
> ** Changed in: drizzle
> Milestone: None => 2010-04-26
>
> ** Also affects: drizzle/cherry
> Importance: High
> Assignee: Brian Aker (brianaker)
> Status: Confirmed
>
> --
> drizzleslap guid test fails
> https://bugs.launchpad.net/bugs/568095
> You received this bug notification because you are a member of Drizzle-
> developers, which is subscribed to Drizzle.
>
> Status in A Lightweight SQL Database for Cloud and Web: Confirmed
> Status in Drizzle cherry series: Confirmed
>
> Bug description:
> As of build 1475, the guid test has failed 5 of 7 times
>
> See the complete log at http://hudson.drizzle.org/view/Drizzle-staging/job/drizzle-staging-drizzleslap/193/
>
> Wed Apr 21 12:36:19 2010 INFO: Running test: guid with /home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap --port=9306 --label=guid --concurrency=50 --iterations=10 --csv=/tmp/drizzleslap-1502.csv --number-int-cols=2 --number-char-cols=3 --auto-generate-sql --auto-generate-sql-guid-primary --auto-generate-sql-load-type=write --number-of-queries=100000 --engine=innodb
> Wed Apr 21 12:39:55 2010 INFO: guid Failed with 256
> /home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap: Cannot run query INSERT INTO t1 VALUES (uuid(),601509202,1905068689,'5dfQWSPWlOQP0HHO5AMpvHa22L9mBXR806QNRrtC7BT7KmYQx...

Read more...

Lee Bieber (kalebral) wrote :

Logfile with verbose turned on is at on 10101 at /home/drizzle/tmp/log.txt

Lee Bieber (kalebral) wrote :

It passes with 1471, running 1472 now

Lee Bieber (kalebral) wrote :

build 1472 fails

Eric Day (eday) wrote :

I was able to reproduce all the way back to 1461, so this isn't too new. Something may have changed more recently that makes it more frequent to hit though.

Eric Day (eday) wrote :

Turns out uuid_generate_time() on this machine is producing duplicate UUIDs, which is really bad. I reproduced this behavior outside of drizzle as well with:

http://oddments.org/wiki/index.php?id=programming:c:uuid_dupes.c

So, in order to guarantee uniqueness we either need to come up with a new uuid function of our own or somehow serialize uuid_generate. A simple mutex may not work since CPU clocks may not always be in sync with each other. We would probably need to keep a small time history of recent UUIDs to provide a guarantee.

On Thu, 29 Apr 2010 22:40:57 -0000, Eric Day <email address hidden> wrote:
> Turns out uuid_generate_time() on this machine is producing duplicate
> UUIDs, which is really bad. I reproduced this behavior outside of
> drizzle as well with:
>
> http://oddments.org/wiki/index.php?id=programming:c:uuid_dupes.c
>
> So, in order to guarantee uniqueness we either need to come up with a
> new uuid function of our own or somehow serialize uuid_generate. A
> simple mutex may not work since CPU clocks may not always be in sync
> with each other. We would probably need to keep a small time history of
> recent UUIDs to provide a guarantee.

Which UUID lib are we using? We should probably fix it.

--
Stewart Smith

Brian Aker (brianaker) wrote :

Hi!

I had suggested this, but didn't think it would be the case (I mean... is the box ever wrong?).

Another possible option, should we adjust the uuid() function in how it is doing the generation?

Cheers,
 -Brian

On Apr 29, 2010, at 3:40 PM, Eric Day wrote:

> Turns out uuid_generate_time() on this machine is producing duplicate
> UUIDs, which is really bad. I reproduced this behavior outside of
> drizzle as well with:
>
> http://oddments.org/wiki/index.php?id=programming:c:uuid_dupes.c
>
> So, in order to guarantee uniqueness we either need to come up with a
> new uuid function of our own or somehow serialize uuid_generate. A
> simple mutex may not work since CPU clocks may not always be in sync
> with each other. We would probably need to keep a small time history of
> recent UUIDs to provide a guarantee.
>
> --
> drizzleslap guid test fails
> https://bugs.launchpad.net/bugs/568095
> You received this bug notification because you are a member of Drizzle-
> developers, which is subscribed to Drizzle.
>
> Status in A Lightweight SQL Database for Cloud and Web: Confirmed
> Status in Drizzle cherry series: Confirmed
>
> Bug description:
> As of build 1475, the guid test has failed 5 of 7 times
>
> See the complete log at http://hudson.drizzle.org/view/Drizzle-staging/job/drizzle-staging-drizzleslap/193/
>
> Wed Apr 21 12:36:19 2010 INFO: Running test: guid with /home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap --port=9306 --label=guid --concurrency=50 --iterations=10 --csv=/tmp/drizzleslap-1502.csv --number-int-cols=2 --number-char-cols=3 --auto-generate-sql --auto-generate-sql-guid-primary --auto-generate-sql-load-type=write --number-of-queries=100000 --engine=innodb
> Wed Apr 21 12:39:55 2010 INFO: guid Failed with 256
> /home/drizzle/repos/staging-drizzleslap-drizzleslap-r1502/client/drizzleslap: Cannot run query INSERT INTO t1 VALUES (uuid(),601509202,1905068689,'5dfQWSPWlOQP0HHO5AMpvHa22L9mBXR806QNRrtC7BT7KmYQxm7k3hmxvojyBB649YRcFChFOAMkxu2mZ9Wcj9Qex9c8KaCWyXy5kfK0ijcfTXH2gfXFoxtlyLmBvq','ZtMXzy3Jql2QGOxZQW4plteXWds8oozLZDkOBfktOeJY29xLf22GvhnHAYQyCPBlWnAhRmQjGlGJm5YH7aQu7DCHdW7pvARPyTyHFOsX10ig66x5hF0oT4yya5oLG7','e6cSFjk76d8pHEn7BSMB9j77iZ4MuKLOIxsZYcheEhJXn7WyRt2SS9bAbYOTklm3aeS6F1dLiokLvFKF0MjSNBXyjnKJZ6M7kr6rkj4RNpoBw0QwM1Ge4fcfRwzsuL') ERROR : Duplicate entry 'a959aff6-4d7d-11df-8dbf-000e0c434fcf' for key 'PRIMARY'
>
>

Lee Bieber (kalebral) on 2010-05-10
Changed in drizzle:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers