Unknown slave config file options crash Drizzle

Bug #956223 reported by Daniel Nichter on 2012-03-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
Confirmed
Undecided
Unassigned

Bug Description

Wrong, bad, unknown, misplaced, etc. config file options in a slave config file cause the slave plugin to crash Drizzle at startup.

To reproduce:

1. Use a config file like:

seconds-between-reconnects=5
max-reconnects=2
[master1]
master-host=127.0.0.1
master-user=slave1
master-pass=foo
master-port=3001

(max-reconnects is misplaced).

2. Start Drizzle and observe it fold like a lawn chair:

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::program_options::unknown_option> >'
  what(): unknown option max-reconnects
120315 11:15:35 - drizzled got signal 6;

Suggested fix: catch errors, print errors, let Drizzle start.

Workaround: fix the slave config file.

Henrik Ingo (hingo) wrote :

See also #935950.

Henrik Ingo (hingo) wrote :

This seems to be fixed in 7.1.32-rc

Changed in drizzle:
status: Confirmed → Fix Released
David Shrewsbury (dshrews) wrote :

Hingo,

Although I have yet to try and reproduce this, I have not seen any fixes come through for it, nor have I put in a fix myself. I think changing it to Fix Released is incorrect here. Invalid would be more correct if you are unable to reproduce the crash.

Henrik Ingo (hingo) wrote :

Sorry: I have mistakenly edited the wrong bug.

Changed in drizzle:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers