Crash on max-allowed-packet option

Bug #935950 reported by Vadim Tkachenko on 2012-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
Confirmed
Undecided
Unassigned

Bug Description

drizzled --user=mysql
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::program_options::invalid_option_value> >'
  what(): in option 'max-allowed-packet': invalid option value '16M'
Aborted (core dumped)

I have
max-allowed-packet = 16M
in drizzled.cnf

Brian Aker (brianaker) on 2012-02-22
Changed in drizzle:
assignee: nobody → Brian Aker (brianaker)
Brian Aker (brianaker) wrote :

Correct syntax is:

max-allowed-packet=16M

No spaces.

Changed in drizzle:
status: New → Invalid
Henrik Ingo (hingo) wrote :

Brian: The point of the bug is that drizzled shouldn't core dump on bad input.

Changed in drizzle:
status: Invalid → Confirmed
Henrik Ingo (hingo) wrote :

low-hanging-fruit because you just need to catch an exception and print a sensible error message, then exit.

Henrik Ingo (hingo) on 2012-03-26
tags: added: low-hanging-fruit
Stewart Smith (stewart) on 2013-01-24
Changed in drizzle:
assignee: Brian Aker (brianaker) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers