Include transaction_reader in Drizzle installations

Bug #746580 reported by David Shrewsbury on 2011-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
Fix Released
Low
David Shrewsbury
7.0
Fix Released
Low
David Shrewsbury
7.1
Fix Released
Low
David Shrewsbury

Bug Description

Currently, the transaction_reader utility is not installed. It is only available if you build the source. This is a useful tool that should be included in Drizzle packaging.

Related branches

On 03/31/2011 01:11 PM, David Shrewsbury wrote:
> Public bug reported:
>
> Currently, the transaction_reader utility is not installed. It is only
> available if you build the source. This is a useful tool that should be
> included in Drizzle packaging.

If we're going to install it - we should read name it -
transaction_reader is a bit generic. Perhaps drizzle_transaction_reader
or something?

Also - be sure to ping Derks and I about this when you get a patch that
moves it from noinst_PROGRAMS to bin_PROGRAMS so that we can update the
debs/rpms appropriately.

AND - I nominate this for elliott. Having that program installed won't
break anyone's existing setups, and it is in fact a useful thing.

Monty

Patrick Crews (patrick-crews) wrote :

My attached branch adds a DRIZZLE_TRX_READER env var that tests can now call (versus the path).
Adjusted transaction_log tests accordingly.

When / if you change the trx_reader name / path, just modify this code to reflect the proper path:
=== modified file 'tests/lib/sys_mgmt/codeTree.py'
--- tests/lib/sys_mgmt/codeTree.py 2011-03-23 18:56:05 +0000
+++ tests/lib/sys_mgmt/codeTree.py 2011-03-31 19:19:53 +0000
@@ -103,6 +103,9 @@
         self.drizzletest = self.system_manager.find_path([os.path.join(self.clientbindir,
                                                    'drizzletest')])

+ self.drizzle_trx_reader = self.system_manager.find_path([os.path.join(self.basedir,
+ 'plugin/transaction_log/utilities/transaction_reader')])
+
         self.server_version_string = None
         self.server_executable = None
         self.server_version = None

David Shrewsbury (dshrews) wrote :

Renaming transaction_reader to drizzle_trx_reader.

David Shrewsbury (dshrews) wrote :

Using 'drizzletrx' as the name instead, after IRC discussion.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers