A Lightweight SQL Database for Cloud Infrastructure and Web Applications

dbqp.py not running on freebsd

Reported by Patrick Crews on 2011-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
Low
Patrick Crews
7.0
Low
Patrick Crews

Bug Description

program is having problems parsing netstat output during port allocation (for test servers).
Need to fix code related to this.

Related branches

Changed in drizzle:
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Patrick Crews (patrick-crews)
milestone: none → 2011-01-31
status: Confirmed → Fix Committed

On Thu, 27 Jan 2011 20:36:36 -0000, Patrick Crews <email address hidden> wrote:
> program is having problems parsing netstat output during port allocation (for test servers).
> Need to fix code related to this.

I'm kind athinking we should just take this opportunity to fix the
server to use the "listen on port 0" trick to have the OS allocate ports
for the test suite - then the MTR_BUILD_NUMBER bonghits can just go away.

--
Stewart Smith

Patrick Crews (patrick-crews) wrote :

Well, I don't have BUILD_THREAD in dbqp (or at least not yet).
We maintain a file listing who has been allocated what ports (still haven't
tried with multiple dbqp's) and we also do a scan to make sure what we
'think' is free really is.
One of the reasons I do this is to allow a user to try to get a specific
master port if they want it.

Of course, this can and likely will change as we know more, but the code for
port allocation and management is nicely contained so we can tweak this more
easily : )

On Fri, Jan 28, 2011 at 7:51 PM, Stewart Smith <email address hidden>wrote:

> On Thu, 27 Jan 2011 20:36:36 -0000, Patrick Crews <
> <email address hidden>> wrote:
> > program is having problems parsing netstat output during port allocation
> (for test servers).
> > Need to fix code related to this.
>
> I'm kind athinking we should just take this opportunity to fix the
> server to use the "listen on port 0" trick to have the OS allocate ports
> for the test suite - then the MTR_BUILD_NUMBER bonghits can just go away.
>
> --
> Stewart Smith
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/708861
>
> Title:
> dbqp.py not running on freebsd
>
> Status in A Lightweight SQL Database for Cloud Infrastructure and Web
> Applications:
> Fix Released
> Status in Drizzle elliott series:
> Fix Released
>
> Bug description:
> program is having problems parsing netstat output during port allocation
> (for test servers).
> Need to fix code related to this.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/drizzle/+bug/708861/+subscribe
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers