port unittests to boost::test

Bug #667162 reported by Monty Taylor
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
Fix Released
Low
Andrew Hutchings
7.0
Fix Released
Low
Andrew Hutchings

Bug Description

The unittests are using google test. At the time, we chose that because the minimum boost version we accepted was too early for boost::test to be sensibly used, but at that time there were no other real differences found.

The API is almost identical... and since we already require boost, it would make more sense to remove the gtest requirement and just use boost.

Related branches

Changed in drizzle:
milestone: none → ongoing
tags: added: low-hanging-fruit
Changed in drizzle:
importance: Undecided → Low
Changed in drizzle:
status: New → Confirmed
Changed in drizzle:
assignee: nobody → Andrew Hutchings (linuxjedi)
Revision history for this message
Patrick Crews (patrick-crews) wrote : Re: [Bug 667162] Re: port unittests to boost::test

3 cheers to you, sir. Thanks for taking this on : )

On Mon, Dec 20, 2010 at 2:29 PM, Andrew Hutchings <<email address hidden>
> wrote:

> ** Changed in: drizzle
> Assignee: (unassigned) => Andrew Hutchings (linuxjedi)
>
> --
> You received this bug notification because you are a member of Drizzle-
> developers, which is subscribed to Drizzle.
> https://bugs.launchpad.net/bugs/667162
>
> Title:
> port unittests to boost::test
>
> Status in A Lightweight SQL Database for Cloud Infrastructure and Web
> Applications:
> Confirmed
>
> Bug description:
> The unittests are using google test. At the time, we chose that because
> the minimum boost version we accepted was too early for boost::test to be
> sensibly used, but at that time there were no other real differences found.
>
> The API is almost identical... and since we already require boost, it would
> make more sense to remove the gtest requirement and just use boost.
>
>
>

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers