drizzledump not dumping auto-inc when connecting to drizzle servers

Bug #652228 reported by Patrick Crews on 2010-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Drizzle
High
Andrew Hutchings
7.0
High
Andrew Hutchings

Bug Description

Randgen testing has shown that AUTO_INCREMENT values are not being captured when using drizzledump to dump MySQL tables:

Output below is from a diff of MySQL vs. a Drizzle server populated via drizzledump output produced against the MySQL server.

 CREATE TABLE `dump_table2` (
   `col_enum_key` ENUM('a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z') DEFAULT NULL,
@@ -42,7 +42,7 @@
   KEY `col_enum_not_null_key` (`col_enum_not_null_key`),
   KEY `col_bigint_key` (`col_bigint_key`),
   KEY `col_char_10_key` (`col_char_10_key`)
-) ENGINE=InnoDB AUTO_INCREMENT=1 COLLATE = utf8_general_ci;
+) ENGINE=InnoDB COLLATE = utf8_general_ci;

I populated the MySQL server via the randgen, using the gendata file conf/drizzle.zz.

If for any reason you'd like additional information or help in reproducing this, just let me know and I'll do what I can.

Related branches

Changed in drizzle:
assignee: nobody → Andrew Hutchings (linuxjedi)
status: New → Confirmed
Changed in drizzle:
importance: Undecided → High
milestone: none → 2010-10-11
status: Confirmed → Triaged
Andrew Hutchings (linuxjedi) wrote :

Is this the output from drizzledump or reading from Drizzle post-import? Auto_increment reading in Drizzle has given weird results (I can't find the bug for it now one, I felt sure I filed one)

I would expect the dump to be correct but SHOW CREATE TABLE after import to be wrong.

Andrew Hutchings (linuxjedi) wrote :

Filed bug#652272 anyway. If that is the cause I will close this one as a dupe.

This diff is from comparing drizzledump files from MySQL vs. Drizzle (after
it has been populated via drizzledump from the MySQL server)

On Thu, Sep 30, 2010 at 2:04 PM, Andrew Hutchings <<email address hidden>
> wrote:

> Filed bug#652272 anyway. If that is the cause I will close this one as
> a dupe.
>
> --
> AUTO_INCREMENT values from MySQL tables not being captured / dumped via
> drizzledump
> https://bugs.launchpad.net/bugs/652228
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in A Lightweight SQL Database for Cloud Infrastructure and Web
> Applications: Triaged
> Status in Drizzle elliott series: Triaged
>
> Bug description:
> Randgen testing has shown that AUTO_INCREMENT values are not being captured
> when using drizzledump to dump MySQL tables:
>
> Output below is from a diff of MySQL vs. a Drizzle server populated via
> drizzledump output produced against the MySQL server.
>
> CREATE TABLE `dump_table2` (
> `col_enum_key`
> ENUM('a','b','c','d','e','f','g','h','i','j','k','l','m','n','o','p','q','r','s','t','u','v','w','x','y','z')
> DEFAULT NULL,
> @@ -42,7 +42,7 @@
> KEY `col_enum_not_null_key` (`col_enum_not_null_key`),
> KEY `col_bigint_key` (`col_bigint_key`),
> KEY `col_char_10_key` (`col_char_10_key`)
> -) ENGINE=InnoDB AUTO_INCREMENT=1 COLLATE = utf8_general_ci;
> +) ENGINE=InnoDB COLLATE = utf8_general_ci;
>
> I populated the MySQL server via the randgen, using the gendata file
> conf/drizzle.zz.
>
> If for any reason you'd like additional information or help in reproducing
> this, just let me know and I'll do what I can.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/drizzle/+bug/652228/+subscribe
>

Download full text (6.2 KiB)

It appears that auto_increment is showing up in SHOW CREATE TABLE output:
drizzle> show create table dump_table1;
+-------------+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Table | Create Table |
+-------------+---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------...

Read more...

summary: - AUTO_INCREMENT values from MySQL tables not being captured / dumped via
- drizzledump
+ drizzledump not dumping auto-inc when connecting to drizzle servers
Changed in drizzle:
status: Triaged → Fix Committed
Lee Bieber (kalebral) on 2010-10-02
Changed in drizzle:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers